Bug 778672 - support for schema import in EBWS WSDL
support for schema import in EBWS WSDL
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0
Unspecified Unspecified
high Severity high
: ---
: 5.0.0 GA,5.0.0 ER2
Assigned To: Mark Little
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 10:16 EST by Taro Yasuma
Modified: 2012-07-13 00:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: SOA-1142
Environment:
Last Closed: 2010-01-28 06:23:59 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
publish_as_webservice_import_NG.zip (32.63 KB, application/zip)
2009-01-21 10:20 EST, Taro Yasuma
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1142 None None None Never

  None (edit)
Description Taro Yasuma 2009-01-21 10:16:17 EST
++ This bug is a clone of bug 778671 ++

Date of First Response: 2010-01-28 06:23:59
Help Desk Ticket Reference: https://enterprise.redhat.com/issue-tracker/254594
project_key: SOA

When you set a schema file which imports another schema file in inXsd or/and outXsd, the deployment of the EBWS fails.

Example of importing schema file)

<xs:schema version="1.0" targetNamespace="http://www.jboss.org/sayHi" xmlns:x1="http://www.jboss.org/sayHi"  xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified">
<xs:import namespace="http://www.jboss.org/sayHi"
       schemaLocation="request_imp.xsd" />
  <xs:element name="sayHi" type="x1:sayHi"/>
</xs:schema>


HOW TO REPRODUCE:

1. Unzip the attached publish_as_webservice_import_NG.zip

2. $ant deploy

Then, you'll see the deployment failure of the wsdl and the service with the following:

Caused by: java.io.IOException: Cannot get URL for: WEB-INF/wsdl//ESBServiceSample/request_imp.xsd
	at org.jboss.wsf.common.URLLoaderAdapter.findChild(Unknown Source)
	at org.jboss.wsf.framework.deployment.ArchiveDeploymentImpl.getMetaDataFileURL(Unknown Source)
	at org.jboss.wsf.stack.jbws.WSDLFilePublisher.publishSchemaImports(WSDLFilePublisher.java:239)
	at org.jboss.wsf.stack.jbws.WSDLFilePublisher.publishSchemaImports(WSDLFilePublisher.java:260)
	at org.jboss.wsf.stack.jbws.WSDLFilePublisher.publishSchemaImports(WSDLFilePublisher.java:260)
	at org.jboss.wsf.stack.jbws.WSDLFilePublisher.publishWsdlFiles(WSDLFilePublisher.java:129)
	... 33 more
Comment 1 Taro Yasuma 2009-01-21 10:17:56 EST
Link: Added: This issue depends JBESB-2283
Comment 2 Taro Yasuma 2009-01-21 10:18:32 EST
Link: Added: This issue depends JBESB-2217
Comment 3 Taro Yasuma 2009-01-21 10:20:35 EST
Added the sample application based on publish_as_webservice.
Comment 4 Taro Yasuma 2009-01-21 10:20:35 EST
Attachment: Added: publish_as_webservice_import_NG.zip
Comment 5 Taro Yasuma 2009-01-21 10:25:31 EST
Link: Added: This issue is related to SOA-1137
Comment 6 Kevin Conner 2009-05-21 05:29:30 EDT
Link: Removed: This issue depends JBESB-2217 
Comment 7 Kevin Conner 2009-05-21 05:29:48 EDT
Link: Added: This issue depends JBESB-2323
Comment 8 Kevin Conner 2009-05-21 05:30:40 EDT
Link: Removed: This issue depends JBESB-2283 
Comment 9 Len DiMaggio 2009-11-02 11:37:17 EST
Link: Added: This issue is a dependency of SOA-1558
Comment 10 Martin Vecera 2010-01-28 06:23:59 EST
Verified in ER7.

Note You need to log in before you can comment on or make changes to this bug.