Bug 778727 - The issue logged in SOA-1186 causes the publish_as_webservice_inonly quickstart to fail - the test runs, but no data is returned to the client
The issue logged in SOA-1186 causes the publish_as_webservice_inonly quicksta...
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Examples (Show other bugs)
5.0
Unspecified Unspecified
high Severity high
: ---
: 5.0.0 GA
Assigned To: Tom Fennelly
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 15:03 EST by Len DiMaggio
Modified: 2012-07-13 00:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: SOA-1187
Environment:
4.3 CP01 CR3
Last Closed: 2010-02-08 12:31:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1187 None None None Never

  None (edit)
Description Len DiMaggio 2009-02-20 15:03:54 EST
++ This bug is a clone of bug 778726 ++

Date of First Response: 2009-02-25 06:46:46
project_key: SOA

The issue logged in SOA-1186 causes the publish_as_webservice_inonly quickstart to fail - the test runs, but no data is returned to the client
Comment 1 Len DiMaggio 2009-02-20 15:06:37 EST
Link: Added: This issue depends SOA-1186
Comment 2 Tom Fennelly 2009-02-25 06:46:46 EST
Len, can you explain this some more please?  This quickstart is supposed to return an empty response.  It's "inonly"!!
Comment 3 Len DiMaggio 2009-02-25 13:12:06 EST
Hey Tom - the quickstart reuses the SOAPTest class from publish_as_webservice:

try {
                        client.executeMethod(postMethod);
                        System.out.println("Response from web service");
                        System.out.println("[" + postMethod.getResponseBodyAsString() + "]");
                } 

This would make it clearer:
                        System.out.println("Response from web service - should be empty");


As when the test runs, it displays:

runtest:
     [echo] Send soap message to published web service and receive reponse
     [java] Response from web service
     [java] []
     [echo] 
     [echo] 
     [echo] Send soap message to published web service and receive soap fault message
     [java] Response from web service
     [java] []

The readme also has the user:

To Run from Soapui:
===========================
  1. Use the following URL: 'http://127.0.0.1:8080/Quickstart_publish_as_webservice_inonly/ESBServiceSample/HelloWorldPubService?wsdl'.
  2. Copy the contents of soap-userpass-message.xml.
  3. Exceute the web service call from soapui.

But - that URL does not return the WSDL - due to SOA-1186.


Comment 4 Tom Fennelly 2009-02-25 13:40:31 EST
okidoki... thanks Len... so this particular issue is a "documentation" one.  The wsdl being filtered out is def a bug (SOA-1186). 
Comment 5 Mark Little 2009-03-09 06:42:17 EDT
Moving to CP.
Comment 6 Len DiMaggio 2010-02-08 12:31:51 EST
The quickstart 'publish_as_webservice_inonly' is not in 4.3 CP02 or 5.0 CR1

Note You need to log in before you can comment on or make changes to this bug.