This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 778732 - (SOA-1190) Systinet registry integration
Systinet registry integration
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 5.0.0 GA,5.0.0 ER5
Assigned To: tcunning
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 05:52 EST by Mark Little
Modified: 2010-02-03 15:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-03 15:57:28 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
stacktrace.log (4.09 KB, text/x-log)
2010-01-28 09:53 EST, Jiri Sedlacek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBESB-2649 None None None Never
JBoss Issue Tracker SOA-1190 None None None Never

  None (edit)
Description Mark Little 2009-02-24 05:52:39 EST
Date of First Response: 2009-05-21 07:27:24
project_key: SOA
Comment 1 Kevin Conner 2009-05-21 07:27:24 EDT
There is still one aspect to handle on this, the issue of co-located registry.

At present systinet only has an HTTP transport which means that the ESB cannot be located within the same server as the registry.  Tom is investigating solutions.
Comment 2 tcunning 2009-06-26 20:33:58 EDT
Link: Added: This issue related JBESB-2649
Comment 4 Jiri Sedlacek 2010-01-28 09:53:48 EST
Attachment: Added: stacktrace.log
Comment 5 tcunning 2010-01-28 11:01:30 EST
Len asked me to comment on this one - here's where I believe we are on this one.       We created a mock servlet implementation of a Systinet transport (JBESB-2649).     We would like to create a cleaner transport - one that implements Systinet's interfaces (JBESB-2783) for a future release.

The mock servlet implementation is in product/tools/systinet - I'm unsure of whether this is being built as part of SOA-P or whether it should be built as part of SOA-P, or whether the plan is to provide this JAR upon request.

Don't know about the stack trace - would need a lot more details like what transport is being used, etc.
Comment 7 tcunning 2010-02-01 16:25:02 EST
I can reproduce what Jiri is seeing as well -  the error seems to be tied to their web framework.        I'm not sure if HP has qualified SOA Registry Foundation on jboss 5.X.
Comment 10 Kevin Conner 2010-02-03 03:29:07 EST
Also, can we move the stacktrace to a new issue??
Comment 11 Len DiMaggio 2010-02-03 15:56:10 EST
Link: Added: This issue related SOA-1919
Comment 12 Len DiMaggio 2010-02-03 15:56:44 EST
The stack trace issue is tracked here:  SOA-1190
Comment 13 Len DiMaggio 2010-02-03 15:57:28 EST
See SOA-1919 for related issue.

Note You need to log in before you can comment on or make changes to this bug.