Bug 778749 - 4.3 CP01 server, configured with DB2 by schema tool, fails to start with SQL error
4.3 CP01 server, configured with DB2 by schema tool, fails to start with SQL ...
Status: CLOSED NOTABUG
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Tooling, JBossESB (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jim Ma
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 14:27 EST by Len DiMaggio
Modified: 2012-07-13 00:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: SOA-1205
Environment:
Last Closed: 2009-03-06 11:13:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
standalone_server.log.zip (13.84 KB, application/zip)
2009-03-04 14:28 EST, Len DiMaggio
no flags Details
embedded_server.log.zip (26.07 KB, application/zip)
2009-03-04 14:28 EST, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1205 None None None Never

  None (edit)
Description Len DiMaggio 2009-03-04 14:27:02 EST
++ This bug is a clone of bug 778748 ++

Date of First Response: 2009-03-06 01:50:02
project_key: SOA

After running the SQL commands referenced in SOA-1204 manually as a SYSADM level user, and configuring a 4.3 embedded or standalone server with DB2 9, seeing these errors (see attached server.logs) starting up the server:


2009-03-04 13:52:39,548 INFO  [org.jboss.jms.server.ServerPeer] JBoss Messaging 1.4.0.SP3-CP04 server [0] started
2009-03-04 13:52:39,607 WARN  [org.jboss.messaging.core.impl.JDBCSupport] SQLException caught, SQLState 42703 code:-206- assuming deadlock detected, try:1
com.ibm.db2.jcc.b.SqlException: DB2 SQL error: SQLCODE: -206, SQLSTATE: 42703, SQLERRMC: CLSTERED
	at com.ibm.db2.jcc.b.hh.c(hh.java:1662)
	at com.ibm.db2.jcc.b.hh.d(hh.java:1650)
	at com.ibm.db2.jcc.b.hh.a(hh.java:1219)
	at com.ibm.db2.jcc.c.db.g(db.java:139)
	at com.ibm.db2.jcc.c.db.a(db.java:39)
	at com.ibm.db2.jcc.c.t.a(t.java:34)
	at com.ibm.db2.jcc.c.sb.f(sb.java:142)
	at com.ibm.db2.jcc.b.hh.n(hh.java:1190)
	at com.ibm.db2.jcc.b.ih.eb(ih.java:1997)
	at com.ibm.db2.jcc.b.ih.d(ih.java:2439)
	at com.ibm.db2.jcc.b.ih.V(ih.java:492)
	at com.ibm.db2.jcc.b.ih.executeQuery(ih.java:475)
	at org.jboss.resource.adapter.jdbc.WrappedPreparedStatement.executeQuery(WrappedPreparedStatement.java:255)
	at org.jboss.messaging.core.impl.postoffice.MessagingPostOffice$1LoadBindings.doTransaction(MessagingPostOffice.java:2487)
	at org.jboss.messaging.core.impl.postoffice.MessagingPostOffice$1LoadBindings.doTransaction(MessagingPostOffice.java:2470)
	at org.jboss.messaging.core.impl.JDBCSupport$JDBCTxRunner.execute(JDBCSupport.java:394)
	at org.jboss.messaging.core.impl.JDBCSupport$JDBCTxRunner.executeWithRetry(JDBCSupport.java:416)
	at org.jboss.messaging.core.impl.postoffice.MessagingPostOffice.getBindingsFromStorage(MessagingPostOffice.java:2538)
	at org.jboss.messaging.core.impl.postoffice.MessagingPostOffice.start(MessagingPostOffice.java:353)
	at org.jboss.messaging.core.jmx.MessagingPostOfficeService.startService(MessagingPostOfficeService.java:456)
	at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:289)
	at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:196)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
	at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
	at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133)
	at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
	at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:142)
	at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
	at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
	at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
	at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:995)
	at $Proxy0.start(Unknown Source)
	at org.jboss.system.ServiceController.start(ServiceController.java:417)
	at org.jboss.system.ServiceController.start(ServiceController.java:435)
	at org.jboss.system.ServiceController.start(ServiceController.java:435)
	at org.jboss.system.ServiceController.start(ServiceController.java:435)
	at org.jboss.system.ServiceController.start(ServiceController.java:435)
	at org.jboss.system.ServiceController.start(ServiceController.java:435)
	at org.jboss.system.ServiceController.start(ServiceController.java:435)
	at org.jboss.system.ServiceController.start(ServiceController.java:435)
	at sun.reflect.GeneratedMethodAccessor12.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke
Comment 1 Len DiMaggio 2009-03-04 14:28:49 EST
Attachment: Added: standalone_server.log.zip
Attachment: Added: embedded_server.log.zip
Comment 2 Len DiMaggio 2009-03-04 14:29:21 EST
Link: Added: This issue is related to SOA-1204
Comment 3 Len DiMaggio 2009-03-04 14:46:09 EST
Link: Added: This issue is a dependency of SOA-630
Comment 4 Jim Ma 2009-03-06 01:50:02 EST
This error is caused by there are old version JBM tables in the database. The JBM1.4.0_SP3 data schema is not compatible with the old version . Please try dropping all the tables before start server .

The right version JBM_POSTOFFICE table shema for JBM1.4.0.SP3_CP04 should be :

Column name  Datatypeschema Datatype Columnname Length Scale Nulls
------------------------------- --------- ------------------- ---------- ----- ------
POSTOFFICE_NAME SYSIBM VARCHAR 255 0 No
NODE_ID SYSIBM SMALLINT 2 0 No
QUEUE_NAME SYSIBM VARCHAR 255 0 No
COND SYSIBM VARCHAR 1023 0 Yes
SELECTOR SYSIBM VARCHAR 1023 0 Yes
CHANNEL_ID SYSIBM INTEGER 4 0 Yes
CLSTERED SYSIBM CHARACTER 1 0 Yes
ALL_NODES SYSIBM CHARACTER 1 0 Yes


The following old version table is in the current database :

[jimma@bin]$ db2 describe table soapuser.jbm_postoffice

Column name  Datatypeschema Datatype Columnname Length Scale Nulls
------------------------------- --------- ------------------- ---------- ----- ------
POSTOFFICE_NAME SYSIBM VARCHAR 255 0 No
NODE_ID SYSIBM INTEGER 4 0 No
QUEUE_NAME SYSIBM VARCHAR 255 0 No
COND SYSIBM VARCHAR 1023 0 Yes
SELECTOR SYSIBM VARCHAR 1023 0 Yes
CHANNEL_ID SYSIBM BIGINT 8 0 Yes
CLUSTERED SYSIBM CHARACTER 1 0 Yes
ALL_NODES SYSIBM CHARACTER 1 0 Yes
Comment 5 Len DiMaggio 2009-03-06 11:13:29 EST
Closing this - the DB was populated with tables in June 2008 - cleaning out the tables resolved the problem.

Note You need to log in before you can comment on or make changes to this bug.