Bug 77882 - rlogin hangs the second time
rlogin hangs the second time
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rsh (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-14 13:57 EST by Need Real Name
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 06:24:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-11-14 13:57:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
rlogin to an aix system works 1 time, after logging out and logging in again 
with rlogin it hangs.
After a very long time it works again.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rlogin 192.9.200.23 -l johan
2.exit
3.rlogin 192.9.200.23 -l johan
	

Actual Results:  hangs in step 3

Additional info:

with netstat I found :
rlogin client on redhat uses the first time socket port 1023, after logging out 
and logging in again with rlogin to the same system, it uses again socket port 
1023 but hangs. Netstat gives as status on the port SYN_SENT.

Rlogin in another shell while the above connection hangs, works again 1 time, 
this time with socket port 1022. After logging out and logging in again, hangs 
again on socket port 1022, netstat gives again SYN_SENT.

To resume :
a recently used socket port to a certain system can't be used anymore for a 
long amount of time to the same system. It can well be used to another system.
For example :

rlogin 192.9.200.23 -l johan
it works (netstat shows socket port 1023 is used)

ctrl-D to logout

rlogin 192.9.200.22 -l johan
it works, (netstat shows socket port 1023 is used again)
rlogin 192.9.200.23 would have hanged

ctrl-D to logout

rlogin again to 192.9.200.23 or 192.9.200.22 hangs now.
netstat gives SYN_SENT on port 1023
Comment 1 Karel Zak 2004-12-17 12:04:32 EST
The "rlogin" use privileged ports (512-1023). The number of this ports
are limited and after terminated connection is some timeout when the
connection on port is in the TIME_WAIT state. I think your AIX server
hasn't free ports for new connection and you need to wait for
TIME_WAIT timeout from previous connection. 

I think you can found something interesting in the server logs. I have
no idea where AIX has logs, but at linux it's in the file
/var/log/messages.

Comment 2 Karel Zak 2005-09-08 06:24:21 EDT
No response. NEEDINFO -> CANTFIX

Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Users who have experienced this problem are encouraged to upgrade to the latest
update release, and if this issue is still reproduceable, please contact the Red
Hat Global Support Services page on our website for technical support options:
https://www.redhat.com/support

If you have a telephone based support contract, you may contact Red Hat at
1-888-GO-REDHAT for technical support for the problem you are experiencing. 


Note You need to log in before you can comment on or make changes to this bug.