Bug 77885 - h2ph incorrectly converts some glibc headers
Summary: h2ph incorrectly converts some glibc headers
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 19:44 UTC by Douglas K. Fischer
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 11:00:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against perl5.005_03 (896 bytes, patch)
2002-11-14 19:45 UTC, Douglas K. Fischer
no flags Details | Diff

Description Douglas K. Fischer 2002-11-14 19:44:26 UTC
Description of problem:

The version of h2ph included with perl < 5.8.0 incorrectly converts glibc header files that 
include versioned elements such as "__GNUC_PREREQ (2,8)".

Version-Release number of selected component (if applicable): perl < 5.8.0

How reproducible:

Always

Steps to Reproduce:

1.With perl < 5.8.0 execute h2ph against /usr/include/sys/cdefs.h or any other header that 
includes such a versioned element as described above.

Additional info:

This bug is corrected by the Perl team in 5.8.0 and requires utils/h2ph.PL to be patched 
(patch attached). This effects any version of Red Hat Linux running perl < 5.8.0

Comment 1 Douglas K. Fischer 2002-11-14 19:45:54 UTC
Created attachment 85125 [details]
Patch against perl5.005_03

Comment 2 Douglas K. Fischer 2002-11-14 19:47:22 UTC
The attached patch is against perl 5.005_03; however, 5.6.0 and 5.6.1 are likewise 
affected and the same patch should apply against those versions as well.

Comment 4 Warren Togami 2005-09-11 11:00:05 UTC
Closing because 7.2 is not a supported product.


Note You need to log in before you can comment on or make changes to this bug.