Bug 779149 - (SOA-1545) Backwards incompatibility with HttpResponse
Backwards incompatibility with HttpResponse
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Documentation, JBossESB, Compatibility (Show other bugs)
5.0.0 ER1
Unspecified Unspecified
high Severity high
: ---
: 5.0.0 GA
Assigned To: Darrin Mison
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-23 04:35 EDT by Lukáš Petrovický
Modified: 2010-03-01 00:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-01 00:13:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1545 None None None Never

  None (edit)
Description Lukáš Petrovický 2009-10-23 04:35:30 EDT
Affects: Documentation (Ref Guide, User Guide, etc.)
Date of First Response: 2009-10-23 11:12:16
project_key: SOA

See JBESB-2903.
Comment 1 Lukáš Petrovický 2009-10-23 04:36:04 EDT
Link: Added: This issue depends JBESB-2903
Comment 2 Kevin Conner 2009-10-23 11:12:16 EDT
The compatibility issue is the result of a deliberate decision, taken when implementing the new HTTP features.  We were allowed leeway in this as it was feeding in to a new SOA 5 stream.
Comment 3 Lukáš Petrovický 2009-10-26 03:31:41 EDT
Ok. In that case, this should be documented in some paper on migrating from SOA-P 4 to 5.
Comment 4 trev 2009-12-02 06:10:34 EST
Needs to be mentioned in any upgrade docs
Comment 5 trev 2009-12-02 06:10:34 EST
Affects: Added: [Documentation (Ref Guide, User Guide, etc.)]
Comment 6 David Le Sage 2010-02-02 00:31:30 EST
Kevin,


Can you please tell us what has changed as we are preparing the release documents now?

Thanks.


David
Comment 7 Kevin Conner 2010-02-03 04:55:00 EST
Link: Added: This issue depends JBESB-2953
Comment 8 Kevin Conner 2010-02-03 04:55:47 EST
Looks like nothing needs to be documented as the issue was later fixed in a separate issue, JBESB-2953.
Comment 9 Kevin Conner 2010-02-03 04:59:33 EST
Correction, the signature of the message has been fixed but the implementation is incorrect.
Comment 10 Kevin Conner 2010-02-03 05:24:28 EST
Link: Added: This issue is related to JBESB-3164
Comment 11 Kevin Conner 2010-02-03 05:33:01 EST
The documentation should contain something like the following

All references to org.jboss.soa.esb.actions.routing.http.HttpResponse and org.jboss.soa.esb.actions.routing.http.HttpHeader must be changed to refer to the new implementations, org.jboss.soa.esb.http.HttpResponse and org.jboss.soa.esb.http.HttpHeader.  In addition invocations of the HttpResponse.getHeaders() method should be replaced with invocations of HttpResponse.getHttpHeaders().

Comment 12 David Le Sage 2010-02-03 17:55:45 EST
I have drafted this for the Migration section of the Release Notes:



HttpResponse

    Change all references to org.jboss.soa.esb.actions.routing.http.HttpResponse
    and org.jboss.soa.esb.actions.routing.http.HttpHeader to refer to
    org.jboss.soa.esb.http.HttpResponse and org.jboss.soa.esb.http.HttpHeader,
    respectively. Also, replace invocations of the HttpResponse.getHeaders() method with
    HttpResponse.getHttpHeaders().
Comment 13 David Le Sage 2010-02-08 00:12:26 EST
Kevin,


Can you please provide a little bit more detail about this issue for the release notes.  I documented it as per the above but we really need a bit more information:

1.  What has changed and where
2. The impact/result of these changes.


Thanks,

David
Comment 14 Kevin Conner 2010-02-25 11:52:48 EST
Hiya David.

Sorry this took so long to reply.

SOA 5 introduced a new HTTP gateway based around servlets rather than JBoss Remoting and, as part of this work, we decided to consolidate the use of Http information across those classes which produced and/or consumed it.  Previously this had involved the HttpRouter class, producing this information using the classes within its local package.  In order to consolidate these classes they were moved into a more appropriate package, however the intention had been to make this change backwardly compatible and then deprecate those classes within org.jboss.soa.esb.actions.routing.http.  Unfortunately this was not successful, leading to the creation of JBESB-3164.

Is this sufficient background for your purpose?

Kev
Comment 15 Darrin Mison 2010-03-01 00:13:25 EST
Updated Migration issue in SOA 5.0.0 Release Notes

HttpResponse is not backwards compatible

The HttpResponse class in 5.0 is not backwards compatible with previous versions because of changes made to unify the ESB HTTP classes. This was done as a part of the new servlet-based HTTP gateway.

Applications and services that use HttpResponse will have to be updated before they can be deployed on JBoss Enterprise SOA Platform 5.0. The changes required are summarized in the table below.

Pre-5.0.0 code                                                                         5.0.0 code
org.jboss.soa.esb.actions.routing.http.HttpResponse     org.jboss.soa.esb.http.HttpResponse
org.jboss.soa.esb.actions.routing.http.HttpHeader          org.jboss.soa.esb.http.HttpHeader
HttpResponse.getHeaders()                                                HttpResponse.getHttpHeaders()

Note You need to log in before you can comment on or make changes to this bug.