Bug 77918 - Unable to shutdown from logout dialog
Unable to shutdown from logout dialog
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-15 06:12 EST by Rob Stewart
Modified: 2013-07-02 18:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 06:01:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Stewart 2002-11-15 06:12:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.1) Gecko/20020826

Description of problem:
On Oct 23 (or there-abouts) I ftp'd down the latest RPM updates and installed
them on my installation. From that point on the shutdown and reboot options
ceased to work on the logout dialogue.
  Also any application that required authentication no longer worked - no errors
or log messages. Only way to run them was to su to root and run them from the shell.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I don't want to reinstall my system to test if I can reproduce the situation,
but needless to say that I can demonstrate the problem on my current set-up on
demand.

1. Attempt to shutdown from gnome logout dialogue (from redhat/gnome menu).

2. Select 'print-conf-gui' from redhat/gnome menu or run from shell.

Actual Results:  1. System logs out, back to X login dialogue.
2. Nothing happens, no errors reported or logged in /var/log/ files.

Expected Results:  1. Machine should have shutdown.
2. application should have launched.

Additional info:

This has also happened with an installation of Redhat 7.3 on an Athlon system.

I do not use 'up2date' because I do not have these machines connected to the
internet, so I have to ferry any updated RPMs from another machine and the
problems only started to occur once I did several updates.
Comment 1 Havoc Pennington 2002-12-13 16:37:37 EST
Works for me, and no other reports of this; what might be 
different about your system? Changed any pam or other configuration?
Comment 2 Rob Stewart 2002-12-14 08:05:30 EST
Nothing special about my configuration, no pam changes at all (I don't even know
where to start with that one).

  However, I have recently recompiled all of the src RPMs for my pentium 4 (yes
*all* of them) and for a short while, during the replacement procedure, the
problem went away. I think it was when I re-done the kernel stuff the problem
re-occurred, but I can't be certain. For your info I've got 'everything' installed.

  Basically from my experience with both 7.3 and 8.0 this problem pops up when
installing new RPMs from the updates site, so I think there's some kinda
conflict between two RPMs - like a file being overwritten (or a chmod).
Comment 3 Jindrich Novy 2004-12-17 06:01:24 EST
Maybe, however I wasn't able to reproduce it any more and I see no
other bug reports for this issue. I'm closing this.

Thanks for the bugreport.

Note You need to log in before you can comment on or make changes to this bug.