Bug 77919 - rpm complains about dependencies that are med
rpm complains about dependencies that are med
Product: Red Hat Linux
Classification: Retired
Component: imlib (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Depends On:
  Show dependency treegraph
Reported: 2002-11-15 06:38 EST by Göran Uddeborg
Modified: 2013-04-02 00:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-01-24 17:42:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2002-11-15 06:38:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Trying to upgrade from imlib version 1.9.13-2.7.x to version 1.9.13-9 works for
imlib-cfgeditor and imlib-devel.  But when after that trying to upgrade the
imlib package itself, rpm complains that the newly installed imlib-cfgeditor and
imlib-devel needs "imlib = 1.9.13".  As if the new imlib package had some other

Version-Release number of selected component (if applicable):4.1-1.06

How reproducible:

Steps to Reproduce:
1.Start with system with version 1.9.13-2.7.x of the imlib packages.
2.Upgrade first imlib-cfgeditor to 1.9.13-9, and then imlib-devel
  uebn> rpm -q imlib imlib-devel imlib-cfgeditor
3.Try to upgrade the main imlib package too
  uebn### env LANG=C rpm -U imlib-1.9.13-9.i386.rpm
  error: Failed dependencies:
        libImlib.so.1 is needed by (installed) sawfish-0.30.3-1
        imlib = 1.9.13 is needed by (installed) imlib-cfgeditor-1.9.13-9
        imlib = 1.9.13 is needed by (installed) imlib-devel-1.9.13-9

Additional info:
To upgrade cleanly, I of course upgrade sawfish at the same time.  That removes
the complaint about sawfish as expected, but the other two remain.

This could of course be some kind of packaging error in imlib. I can't see what,
so I'm posting this under rpm to begin with.

One detail I've observed is that imlib has an epoch, it provides "imlib =
1:1.9.13-2.7.x", while the subpackages requires only the version.  This seems
slightly suspect, but I'm not sure about the intended behaviour here.  And in
any case, the old imlib-1.9.13-2.7.x also uses an epoch.  So if this would have
been the error, it would have shown already when I installed that package, and
not now when upgrading to the one from RH8.0.
Comment 1 Michael Lee Yohe 2002-11-15 11:17:45 EST
That's definitely a strange "chicken-or-the-egg" problem you have there. 
Instead of upgrading the editor and development packages - your workaround (at
present) could be to revert back to the older versions and then upgrade all at once.
Comment 2 Jeff Johnson 2002-11-15 12:38:12 EST
The Requires: in imlib-{cfgeditor,devel} should
be written with an explicit epoch.

Meanwhile, adding imlib-{cfgeditor,devel} to the
same transaction (i.e. just like sawfish) should get
you out of chicken vs. egg.

Off to imlib for Requires: fix ...
Comment 3 Jonathan Blandford 2003-01-24 17:42:22 EST
The epoch is needed in the Requires tag, fixed in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.