Bug 77920 - In STL, assigning a set data structure the values in another "set" by the "=" operator does not work properly
Summary: In STL, assigning a set data structure the values in another "set" by the "="...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 12:39 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 15:02:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-11-15 12:39:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
outline of the code:
set< string > urlset;
for ( i = 0; i < N; i++ ) {
....
urlset = someFunctionWhichReturnsSet(i,...); // Works the first time
i++;
...
}

This works during the first pass of the for loop. Doesn't work from the next
time. I tried the "set.erase()" call and other such tricks.

IT WORKS WITH GCC2.9XXX ( RH 2.96, that is ... both on RH 7.3 and on 8.0 with
compat* packages )

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Write any program like the above
2.Compile it ( does compile )
3.Fails if compiler gcc3.2 ( not checked with other gcc3.x )
Did not work with the one in rawhide too.
	

Actual Results:  The "set" data structure contained no members. set.size()
returned 0 from the second time onwards.
Worked fine with gcc2.95/6

Expected Results:  Whatever happened with gcc2.95/6 was the expected way it
should have run

Additional info:

No error messages as such. The output was not as expected.
I'm sorry if the information I've provided is not enough. Tried my best though!

Severity is mentioned "high" because it is of a lot of importance to developers,
as a lot of my code has stopped working!

Comment 1 Jakub Jelinek 2002-12-04 16:29:04 UTC
Please attach a self-contained (minimal) testcase, not just an outline of what you're
trying to do.

Comment 2 Benjamin Kosnik 2004-10-01 15:02:46 UTC
Never completed bug report. Lacking reproducible test case.

-benjamin


Note You need to log in before you can comment on or make changes to this bug.