This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 779207 - (SOA-1600) jUDDI does not come with SQL scripts
jUDDI does not come with SQL scripts
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Deployment (Show other bugs)
5.0.0 ER3
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.0.2
Assigned To: trev
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 03:01 EST by Jiri Pechanec
Modified: 2010-06-01 02:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 08:25:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1600 None None None Never

  None (edit)
Description Jiri Pechanec 2009-11-16 03:01:14 EST
Date of First Response: 2009-11-16 04:33:06
project_key: SOA

All ESB componets that uses database comes with SQL scripts which is good practice as it decouples db admin and app admin roles. jUDDI 3 now uses Hibernate to access the database but it does not come with scripts - instead the db creation is done by Hibernate. This component should ese the same approach as the others.
Comment 1 Kevin Conner 2009-11-16 04:33:06 EST
Agreed in principle but the juddi release never came with scripts, so neither does our current (project) integration.
Comment 2 Jiri Pechanec 2009-11-16 04:36:48 EST
Clarification
- jUDDI v3 release never came with script, but SOA-P 4.x had come
Comment 3 Kevin Conner 2009-11-16 04:42:24 EST
Correct, SOA-P 4.x came with the scripts because it used juddi v2.  The juddi v2 codebase rolled its own persistence layer and, therefore, required (and provided) the scripts.
Comment 4 Kurt Stam 2009-12-16 13:20:22 EST
If deemed needed the jUDDI project can create them as part of the jUDDI build and ship them. Or do we want to do this as part of productization?
Comment 5 trev 2009-12-21 10:56:45 EST
We try and push as much down into the projects to avoid update and and maintenance problems. For that reason we would prefer this to be driven by the project, but productisation
will assist. 
Comment 6 Kurt Stam 2009-12-22 09:27:39 EST
http://issues.apache.org/jira/browse/JUDDI-329 scheduled for 3.0.1 mid jan,
Comment 8 Jiri Pechanec 2010-02-03 10:29:16 EST
Files are not currently present in SOA-P distribution. For correct integration it has to be ensured that
1) Files are put in juddi_sql directory in jbossesb-registry.sar
2) Initial data are also provided in form of SQL script instead of XML
3) There will be a service that will initialize a database - create and fill
4) Schema tool will support this new way of configuration

Look at jboss.esb for data-source configuration how to do it properly
Comment 9 Marek Baluch 2010-02-03 10:32:50 EST
Link: Added: This issue related SOA-1917
Comment 10 trev 2010-02-08 09:54:22 EST
setup xml provided, will provide a more standard setup in 5.0.1
Comment 11 Darrin Mison 2010-02-15 17:42:16 EST
Added as a known issue to 5.0.0:

jUDDI v3 uses Hibernate to create its database.  This is different to the other ESB components that use SQL scripts.  This will be standardized in a future release.
Comment 12 Kevin Conner 2010-05-14 07:06:55 EDT
Link: Added: This issue depends JBESB-3319
Comment 13 Kevin Conner 2010-05-14 08:29:48 EDT
ESB work has been done, will be in next merge.
Comment 14 Julian Coleman 2010-05-21 08:31:09 EDT
Support for jUDDI database creation is now in the ESB 4.7 branch and added
to the schema tool with revision 5698 of::
  schema-tool/build.xml
  schema-tool/juddi-service.xml (added)

Commit message:
  SOA-1600 
  Change jUDDI database creation to standard and add to schema tool
Comment 15 Jiri Pechanec 2010-05-28 08:25:42 EDT
Verified in CR1
Comment 16 David Le Sage 2010-05-31 23:05:53 EDT
Release Note draft states:



https://jira.jboss.org/jira/browse/SOA-1600

    The jUDDI v3 database was created through the use of Hibernate. This was in contrast to the
    other ESB components, which used SQL scripts. The Schema tool has now been revised to
    support the creation of the jUDDI database.

Note You need to log in before you can comment on or make changes to this bug.