Bug 77921 - serviceconf does not display correctly all services that you can see with chkconfig
serviceconf does not display correctly all services that you can see with chk...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: serviceconf (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-15 07:56 EST by ab
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-15 07:56:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ab 2002-11-15 07:56:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
I have added 3 new services through the chkconfig utility, unfortuantely one of 
those (bundle_processor) cannot be displayed by the serviceconf utility. I 
suppose because of the "tab" indentation of the service that has got a name 
longer than the others as you can see below:
 
 grabber         0:off 1:off 2:off 3:on 4:on 5:on 6:off
 bundle_processor 0:off 1:off 2:off 3:on 4:on 5:on 6:off
 listener        0:off 1:off 2:off 3:on 4:on 5:on 6:off

It seems to be a parsing failure on that.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add a service named bundle_processor (or longer name) through chkconfig 
utility
2.
3.	

Actual Results:  il will be displayed by the chkconfig --list correctly
il will not be displyed at all by the serviceconf


Expected Results:  serviceconf should have displayed all the services that 
chkconfig utility lists

Additional info:
Comment 1 Daniel Walsh 2002-11-15 09:57:14 EST
This bug has been fixed in the current release.  It is available in 8.0

Note You need to log in before you can comment on or make changes to this bug.