Bug 779213 - (SOA-1606) Multiple quickstarts fail on ER3 - DEPLOYMENTS IN ERROR: Deployment "jboss.esb.vfszip...
Multiple quickstarts fail on ER3 - DEPLOYMENTS IN ERROR: Deployment "jboss.es...
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Examples (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 5.0.0 GA,5.0.0 ER8
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
: SOA-1771 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-17 10:11 EST by Len DiMaggio
Modified: 2012-02-28 13:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-03 12:07:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1606 None Closed Multiple quickstarts fail on ER3 - DEPLOYMENTS IN ERROR: Deployment "jboss.esb.vfszip... 2012-05-02 09:20:40 EDT

  None (edit)
Description Len DiMaggio 2009-11-17 10:11:08 EST
Date of First Response: 2009-11-17 11:10:20
project_key: SOA

Seeing this on multiple Quickstarts:

Caused by Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS): DEPLOYMENTS MISSING DEPENDENCIES: Deployment "jboss.esb:service=QuickstartDatabaseInitializer" is missing the following dependencies: Dependency "jboss.jca:name=QuickstartDB,service=DataSourceBinding" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.jca:name=QuickstartDB,service=DataSourceBinding' **") DEPLOYMENTS IN ERROR: Deployment "jboss.esb.vfszip:/qa/home/ldimaggi/redhat_svn/qa/tests/quickstarts/tests/output/lib/Quickstart_helloworld_hibernate_action.esb/" is in error due to the following reason(s): java.lang.NullPointerException Deployment "jboss.jca:name=QuickstartDB,service=DataSourceBinding" is in error due to the following reason(s): ** NOT FOUND Depends on 'jboss.jca:name=QuickstartDB,service=DataSourceBinding'

With the helloworld* QS's all the SQL, hibernate, EJB3 quickstarts are failing.

Looks like this is the same issue as https://jira.jboss.org/jira/browse/JBESB-2956
Comment 1 Len DiMaggio 2009-11-17 10:12:23 EST
Link: Added: This issue depends JBESB-2956
Comment 2 Len DiMaggio 2009-11-17 10:19:18 EST
Failing quickstarts:

helloworld_ejb3. helloworld_hibernate_action, helloworld_sql_action, helloworld_tx_sql_action

(among the helloworld* quickstarts at least - haven't run all tests yet)

Comment 3 Kevin Conner 2009-11-17 11:10:20 EST
Daniel has logged an app server issue against this, JBAS-7438, but we can look at working around this if it is not addressed in EAP.

As far as I am aware there are only four quickstarts that may be affected by this, helloworld_hibernate_action, helloworld_sql_action, helloworld_tx_sql_action and jms_transacted.
Comment 4 Kevin Conner 2009-11-17 11:10:54 EST
Link: Added: This issue depends JBAS-7438
Comment 5 Kevin Conner 2009-11-17 11:12:15 EST
BTW what is helloworld_ejb3?
Comment 6 Kevin Conner 2009-12-17 10:13:07 EST
Link: Added: This issue depends JBESB-3070
Comment 7 Kevin Conner 2010-01-06 04:28:13 EST
Link: Added: This issue is duplicated by SOA-1771
Comment 8 Aleksandar Kostadinov 2010-01-08 05:40:21 EST
Link: Added: This issue is related to JBQA-2762
Comment 9 Daniel Bevenius 2010-01-18 06:10:05 EST
As far as I can tell the only quickstart that is effected by this is currently helloworld_tx_sql_action. The other quickstarts mentioned about have jms destination definition files and they will work for that reason.

For the helloworld_tx_sql_action is simply creating an empty dummy-service.xml a valid "fix" for this issue?
Comment 10 Kevin Conner 2010-01-18 06:37:52 EST
JBESB-3070 is not intended to "fix" the issue, just to workaround it.  As such the dummy service.xml file is good enough.
Comment 11 trev 2010-02-03 06:47:16 EST
using dummy.xml workaround
Comment 12 Len DiMaggio 2010-02-03 12:07:30 EST
Verified in ER8.


Note You need to log in before you can comment on or make changes to this bug.