Bug 7794 - IDE/SCSI fight for MBR and root partition
IDE/SCSI fight for MBR and root partition
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
Depends On:
  Show dependency treegraph
Reported: 1999-12-13 16:02 EST by Mr. Berkley Shands
Modified: 2015-01-07 18:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-02-22 13:53:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mr. Berkley Shands 1999-12-13 16:02:55 EST
Doing a clean install of 6.1, disk druid wants to put "/" on the
IDE drive, if both IDE and SCSI are available. Regardless of what
partition and disk is selected, disk druid ALWAYS puts "/" on hda1
not sda1. Even if you create the partition as "/1" and then rename it
with "edit". I just took the IDE out of the machine (and unconfigured it
from the bios), then it installed to the correct place.
However, on an identical system, I had NetBSD 1.4.1 installed on the
IDE drive, and tried to do a scsi-install with 6.1 (both over the net and
from CD). This time it let me have "/" on sda1, but it wrote
lilo in the MBR on the IDE disk, and trashed the partition table
on the IDE. Not very friendly, thank you. :-) :-)
Who is hung up on IDE ? this is a P3-600 768mb aha-2940u2w pro 10/100+
machine. I can specify what I want to boot.

Comment 1 Jay Turner 2000-02-22 13:53:59 EST
Issue is resolved in the latest cut of the installer (available in beta)

Note You need to log in before you can comment on or make changes to this bug.