Bug 779571 (SOA-1947) - JDBC Exception thrown when deploying a jboss esb service which has it's description attribute set to an empty String.
Summary: JDBC Exception thrown when deploying a jboss esb service which has it's descr...
Status: CLOSED NEXTRELEASE
Alias: SOA-1947
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Deployment, Examples, jUDDI - within SOA   
(Show other bugs)
Version: 5.0.0 CR1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 5.1.0 GA
Assignee: Kevin Conner
QA Contact:
URL: http://jira.jboss.org/jira/browse/SOA...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-11 13:07 UTC by Marek Baluch
Modified: 2011-02-11 06:16 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-11 06:16:33 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1947 None None None Never

Description Marek Baluch 2010-02-11 13:07:19 UTC
Date of First Response: 2010-02-11 08:47:49
project_key: SOA

See linked issue.

Comment 1 Marek Baluch 2010-02-11 13:07:39 UTC
Link: Added: This issue depends JBESB-3180


Comment 2 Kevin Conner 2010-02-11 13:47:49 UTC
We already work around a similar issue for the service binding EPRs, but it would be nicer if the juddi integration could handle this cleanly.

Comment 3 Marek Baluch 2010-02-11 13:52:08 UTC
As Kevin commented this is a jUDDI issue therefore adding also "jUDDI - withing SOA" component.

Comment 4 Anne-Louise Tangring 2010-09-21 19:47:36 UTC
This is a candidate for SOA 5.1.0. Not committed.

Comment 5 Anne-Louise Tangring 2010-12-02 16:33:20 UTC
This is not a blocker for SOA 5.1.0

Comment 6 Kevin Conner 2010-12-03 12:55:43 UTC
Updated in the ESB codebase.

Comment 8 Dana Mison 2011-01-05 00:14:36 UTC
Writer: Added: dlesage


Comment 9 Marek Baluch 2011-01-07 15:17:51 UTC
Verified on ER6.

Comment 10 David Le Sage 2011-02-11 06:10:59 UTC
Temporarily reopening to update release note info.

Comment 11 David Le Sage 2011-02-11 06:15:33 UTC
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/JBESB-3180

If the user deployed a JBoss ESB service for which the description attribute was set to "", an exception would occur when the  service was registered in jUDDI if the Oracle10g database was being used. This was caused by a problem with jUDDI. To bypass it, the ESB has been changed to ensure that a service description is present.


Comment 12 David Le Sage 2011-02-11 06:16:23 UTC
Release Notes Text: Removed: https://issues.jboss.org/browse/JBESB-3180

If the user deployed a JBoss ESB service for which the description attribute was set to "", an exception would occur when the  service was registered in jUDDI if the Oracle10g database was being used. This was caused by a problem with jUDDI. To bypass it, the ESB has been changed to ensure that a service description is present. Added: https://issues.jboss.org/browse/JBESB-3180

If the user deployed a JBoss ESB service for which the description attribute was set to "", an exception would occur when the  service was registered in jUDDI if the Oracle10g database was being used. This was caused by a problem with jUDDI. To bypass this issue, the ESB has been changed. It now ensures that a service description is present.



Note You need to log in before you can comment on or make changes to this bug.