Bug 779613 - (SOA-1983) javax.jms.IllegalStateException thrown when invoking proxied service with SyncServiceInvoker
javax.jms.IllegalStateException thrown when invoking proxied service with Syn...
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-08 11:02 EST by Boris Belovic
Modified: 2011-02-11 01:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-11 01:04:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1983 None None None Never

  None (edit)
Description Boris Belovic 2010-03-08 11:02:38 EST
project_key: SOA

See linked issue for details.
Comment 1 Boris Belovic 2010-03-08 11:02:56 EST
Link: Added: This issue is related to JBESB-3201
Comment 2 Anne-Louise Tangring 2010-09-21 16:24:13 EDT
This is a candidate for SOA 5.1.0. Not committed. Given that the related JIRA is on ESB, I'm taking a guess here and adding that component. If that is wrong, please fix. 
Comment 3 Kevin Conner 2010-10-06 08:38:54 EDT
I have changed the ESB issue to a blocker for 5.1, doing the same with this SOA issue.
Comment 5 Darrin Mison 2011-01-04 19:14:28 EST
Writer: Added: dlesage
Comment 6 Boris Belovic 2011-02-09 04:43:16 EST
Verified with SOA-P 5.1 ER9 build. There is no exception thrown in ER9 when service C is called from service A.
Comment 7 David Le Sage 2011-02-11 00:59:48 EST
Temporarily reopening to update release note info.
Comment 8 David Le Sage 2011-02-11 01:04:41 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/JBESB-3201

A javax.jms.IllegalStateException was thrown when the SyncServiceInvoker  was used to invoke a proxied service. This was because of poor tracking of XA sessions returned to the pool, leading to conflicts.  To fix this issue, some code changes have been made so that the software now tracks session users, producers and consumers and the caching of XA sessions. As a result, this exception no longer occurs.

Note You need to log in before you can comment on or make changes to this bug.