Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 77963 - sendmail does not work
sendmail does not work
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
k5di@zianet.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-15 17:08 EST by Karl F. Larsen
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-03 16:29:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This shows what /var/log/maillog says and why (980 bytes, text/plain)
2002-12-02 18:11 EST, Karl F. Larsen
no flags Details

  None (edit)
Description Karl F. Larsen 2002-11-15 17:08:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When I set pine to use sendmail my e-mail does not go out. I can later as root
do 'sendmail -q' and it says no que but it then sends out all the stored up
mail. Before I knew it was not working I had 52 messages qued up. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.write an e-mail and send it.
2.Notice the modem has sent out nothing.

3.As root type # sendmail -q
	

Actual Results:  When the sendmail -q is done all the e-mail is sent out

Expected Results:  It should have gone out right after sending the e-mail

Additional info:
Comment 1 Florian La Roche 2002-12-02 16:49:03 EST
Can you please test the current sendmail rpms on
http://people.redhat.com/laroche/ and check if they
work ok? Also what warning/error messages are in
/var/log/maillog prior to running "sendmail -q"?

Thanks a lot,

Florian La Roche
Comment 2 Karl F. Larsen 2002-12-02 18:11:31 EST
Created attachment 87104 [details]
This shows what /var/log/maillog says and why
Comment 3 Karl F. Larsen 2002-12-02 22:11:39 EST
Hello, well I got the 2 rpm files from your web page and both work fine on my
Red Hat 8 system. I left  sendmail-8.12.6-4.i386.rpm
installed but so far as I could tell both worked fine and the one shipped with
Red Hat 8 does not. 

Might not be your area but "postfix" is a huge pain in the ass! It seems to
interfer with sendmail and when I use postfix start ALL e-mail out stops! So
will be careful to not use postfix and it sure needs fixing. I have 2 messages
lost in the HUGE directory mess off /var/.
Comment 4 Florian La Roche 2002-12-03 03:00:42 EST
Ok, closing this bug if things work for you now. If you have
reproducable problems with postfix, feel free to enter them
into bugzilla, too.

Thanks a lot,

Florian La Roche
Comment 5 Karl F. Larsen 2002-12-03 16:29:50 EST
Sorry to say, I discovered the problem is not which rpm of sendmail is used, but
rather what turned it "on". I brought up the computer and sent several e-mails
and assummed they went out. But later in the day I checked and my mail had not
gone out! I used mailp and saw there were 3 messages held up.I used sendmail -q
and out they went. 

Then I turned senmail off. And then restarted it and it came up again and this
time it's working properly again. So it's the manner that sendmail is started
that effects it's performance. As root I used sendmail -bp to load it as a
demon. In man sendmail it states that postfix is what starts sendmail now. That
may be the problem.


Comment 6 Karl F. Larsen 2002-12-04 17:16:11 EST
        It is now apparent that there is nothing wrong with Sendmail or
Postfix. What is wrong is my inability to understand either system. This is
compounded by the Red Hat manuals which are mutually counter-dict-ave. The
Mail Transport Agent Switcher does not work as shown in the manual. When I
use #/sbin/service postfix stop it fails. I'm convinced that some
interaction between postfix and sendmail account for my problem. I have
wasted 3 days of work trying to fix this problem and must now just quit.


Note You need to log in before you can comment on or make changes to this bug.