Bug 779650 - (SOA-2019) RuleAgent could not get the RuleBase (BRMS5+SOA5) can't find properties file
RuleAgent could not get the RuleBase (BRMS5+SOA5) can't find properties file
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Default User
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-30 13:13 EDT by Burr Sutter
Modified: 2013-03-29 06:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Windows7 Java 1.6 32-bit - JBDS 3.0, BRMS 5.0, SOA 5.0
Last Closed: 2010-09-22 11:54:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ESBTestBRMS.zip (18.58 KB, application/zip)
2010-03-30 13:15 EDT, Burr Sutter
no flags Details
repository_export(5).zip (17.54 KB, application/zip)
2010-03-30 13:15 EDT, Burr Sutter
no flags Details
ESBTestBRMS.esb (7.61 KB, application/octet-stream)
2010-03-30 13:15 EDT, Burr Sutter
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2019 Major Closed RuleAgent could not get the RuleBase (BRMS5+SOA5) can't find properties file 2013-03-29 07:06:47 EDT

  None (edit)
Description Burr Sutter 2010-03-30 13:13:34 EDT
Workaround Description: Drop the .properties files into jbrules.esb, then it all works well.
project_key: SOA

    <action class="org.jboss.soa.esb.actions.BusinessRulesProcessor" name="testBRMS">
     <property name="object-paths">
      <object-path esb="body.orderHeader"/>
      <object-path esb="body.customer"/>
     </property>
     <property name="ruleAgentProperties" value="brmsPriorityRules.properties"/>
    </action>

The brmsPriorityRules.properties needs to be dropped into the jbrules.esb (or some other place in the classpath) it is not read from the .esb archive (zipped nor exploded).

Attached is the JBDS project.
The .esb archive from the deploy directory (.properties file inside)
A repository export for the BRMS
Comment 1 Burr Sutter 2010-03-30 13:15:05 EDT
Attachment: Added: ESBTestBRMS.zip
Attachment: Added: repository_export(5).zip
Attachment: Added: ESBTestBRMS.esb
Comment 2 Burr Sutter 2010-03-30 13:15:58 EDT
Workaround Description: Added: Drop the .properties files into jbrules.esb, then it all works well.
Comment 4 Kevin Conner 2011-05-18 06:49:24 EDT
java.lang.NullPointerException
	java.util.Properties$LineReader.readLine(Properties.java:435)
	java.util.Properties.load0(Properties.java:354)
	java.util.Properties.load(Properties.java:342)
	org.drools.agent.RuleAgent.loadFromProperties(RuleAgent.java:299)
	org.drools.agent.RuleAgent.newRuleAgent(RuleAgent.java:273)
Comment 5 Kevin Conner 2011-05-18 07:22:41 EDT
This seems to have been caused by two issues, the fact that the drools code base did not refer to the TCCL and the fact that the initial http support caused the esb deployment to be scoped.

In SOA 5.1 we parse the properties ourselves and we have created a separate deployment for the http/ebws aspects.

Note You need to log in before you can comment on or make changes to this bug.