Bug 779656 - Expose complete SOAP message when exposing ESB as a WS
Expose complete SOAP message when exposing ESB as a WS
Status: CLOSED DUPLICATE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Default User
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-31 10:31 EDT by Lennart Petersson
Modified: 2012-07-13 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: SOA-2023
Environment:
Last Closed: 2010-04-01 09:35:56 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2023 None None None Never

  None (edit)
Description Lennart Petersson 2010-03-31 10:31:54 EDT
++ This bug is a clone of bug 779655 ++

Help Desk Ticket Reference: https://support.redhat.com/jbossnetwork/restricted/caseDetail.html?caseId=376239
project_key: SOA

We are deploying an ESB service and exposing it as a WS by the simple use of in/out/fault xsd on the service element. What is a pity is that we are not able to get hold of SOAP Header parameters from the incoming request in the action pipeline, and also not able to specify SOAP parameters for the response message.

This would be very good if it could be supported. Preferable via a service configuration - should SOAP parts be stripped away or not. Can really not see why this was not supported from the beginning since it should be a rather common scenario. The alternative approaches to expose ESB as a WS, works as a workaround, but they are to 'complicated'. Like this simple way better...

regards,

Lennart Petersson
Redpill Linpro
Comment 1 Lennart Petersson 2010-04-01 09:35:56 EDT
https://jira.jboss.org/jira/browse/JBESB-3260

Note You need to log in before you can comment on or make changes to this bug.