This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 77975 - RHL 7.2 (patched) up2date 2.8.39-1.7.2 Attribute error
RHL 7.2 (patched) up2date 2.8.39-1.7.2 Attribute error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-16 00:59 EST by R P Herrold
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-16 00:59:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2002-11-16 00:59:46 EST
My host:  router/basement

... it seems to be sying simply trying to determine rpmdb attributes -- no
config files have been manually editeedl nothing has EVER been forced or
no-depped in --- I am trying to get a clean build of JBJ's test candidate rpm-
test candidate on this RHL .7.2 box =--- not too hopeful there.

open("/usr/share/rhn/up2date_client/rpmUtils.py", O_RDONLY) = 4
write(2, "  File \"/usr/share/rhn/up2date_c"..., 74  File
"/usr/share/rhn/up2date_client/rpmUtils.py", line 50, in openrpmdb
) = 74
fstat64(4, {st_mode=S_IFREG|0755, st_size=15743, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x401ae000
read(4, "#!/usr/bin/python\n# some high le"..., 4096) = 4096
write(2, "    ", 4    )                     = 4
write(2, "db = rpm.opendb(option)\n", 24db = rpm.opendb(option)
) = 24
close(4)                                = 0
munmap(0x401ae000, 4096)                = 0
write(2, "AttributeError", 14AttributeError)          = 14
write(2, ": ", 2: )                       = 2
write(2, "opendb", 6opendb)                   = 6
write(2, "\n", 1
)                       = 1
close(3)                                = 0
munmap(0x40017000, 4096)                = 0
rt_sigaction(SIGINT, {SIG_DFL}, {0x4002c468, [INT], SA_RESTART|0x4000000}, 8) = 0
_exit(1)                                = ?
[root@router dl]# rpm -q up2date rpm python python2
up2date-2.8.39-1.7.2
rpm-4.1-1.07.7x
python-1.5.2-38
python2-2.2-16
[root@router dl]# up2date --nox -p
Traceback (innermost last):
  File "/usr/sbin/up2date", line 17, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 8, in ?
    import up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 11, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 15, in ?
    import rpmUtils
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 274, in ?
    rpm_version = getRpmVersion()
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 265, in getRpmVersion
    db = openrpmdb()
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 50, in openrpmdb
    db = rpm.opendb(option)
AttributeError: opendb
[root@router dl]# cat /etc/redhat-release
Red Hat Linux release 7.2 (Enigma)
[root@router dl]#
Comment 1 Adrian Likins 2002-12-02 17:25:15 EST
if that release candidate rpm is from the 4.1 or 4.2 series, it's not
going to work with up2date on 6.2-7.x (the python api changed).

That looks like the case here.

Note You need to log in before you can comment on or make changes to this bug.