Bug 779808 - (SOA-2171) http-client-properties not propagated to HttpMethodParams
http-client-properties not propagated to HttpMethodParams
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Unspecified
high Severity high
: ---
: 5.1.0.ER1
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 11:56 EDT by david.boeren
Modified: 2011-03-02 19:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-02 19:22:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2171 Major Closed http-client-properties not propagated to HttpMethodParams 2013-09-11 07:30:28 EDT

  None (edit)
Description david.boeren 2010-07-23 11:56:47 EDT
Help Desk Ticket Reference: https://access.redhat.com/issue-tracker/?module=issues&action=view&tid=1148953&gid=1354
Workaround Description: There is no known workaround.
project_key: SOA

If you set your config like this:

<action ... class="org.jboss.soa.esb.actions.soap.proxy.SOAPProxy">
    ...
    <property name="http-client-properties">
        <http-client-property name="http.method.retry-handler" value="com.foobar.MyRetryHandler"/>
    </property>

or like this:

<action ... class="org.jboss.soa.esb.actions.soap.proxy.SOAPProxy">
    ...
    <property name="file" value="http-client.properties"/>

http-client.properties:
http.method.retry-handler=com.foobar.MyRetryHandler

, your custom retry handler is not picked up. This is NOT a bug in SOAPProxy.

The bug is in both POSTHttpMethodFactory and GETHttpMethodFactory, where in the setConfiguration(ConfigTree):void method, the http-client-properties that are available in the passed-in ConfigTree are not set into the HttpMethod's HttpMethodParams.

What should happen is that ANY property that starts with "http.method." should be set into the HttpMethodParams.
Comment 1 david.boeren 2010-07-23 11:57:28 EDT
Link: Added: This issue depends JBESB-3378
Comment 2 Darran Lofthouse 2010-08-09 07:28:17 EDT
Link: Added: This issue is incorporated by SOA-2210
Comment 3 Kevin Conner 2010-08-10 11:14:52 EDT
Link: Removed: This issue is incorporated by SOA-2210 
Comment 4 Kevin Conner 2010-08-10 12:29:19 EDT
Link: Added: This issue related SOA-2224
Comment 5 Kevin Conner 2010-08-20 05:49:47 EDT
Link: Added: This issue depends JBESB-3468
Comment 6 Anne-Louise Tangring 2010-09-10 12:23:56 EDT
According to Kevin, this is not a valid issue as reported. Even so, it's post ESB 4.9. Actual issues related to this are resolved and in 5.1 already.
Comment 7 Kevin Conner 2010-09-10 12:29:14 EDT
To clarify, the suggested fix is not valid as it is not possible to propagate all 'http.method.' properties to the HttpMethodParams.

The specific issue of configuring the retry handler has been addressed in JBESB-3378.
Comment 8 David Le Sage 2011-03-01 00:30:52 EST
Temporarily reopening to update release note info.
Comment 9 David Le Sage 2011-03-01 00:37:23 EST
https://issues.jboss.org/browse/JBESB-3378

There was a bug in both POSTHttpMethodFactory and GETHttpMethodFactory, in which the setConfiguration(ConfigTree):void method's http-client-properties were not set into the HttpMethod's HttpMethodParams. This meant that any custom retry handlers were ignored.  This bug has now been rectified so that any property that starts with "http.method." is set into HttpMethodParams. As a result, custom retry handlers are now detected correctly.
Comment 10 David Le Sage 2011-03-01 00:37:23 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Writer: Added: dlesage
Comment 11 David Le Sage 2011-03-02 19:21:59 EST
Temporarily reopening to fix release note.
Comment 12 David Le Sage 2011-03-02 19:22:14 EST
Release Notes Text: Added: https://issues.jboss.org/browse/JBESB-3378

There was a bug in both POSTHttpMethodFactory and GETHttpMethodFactory, in which the setConfiguration(ConfigTree):void method's http-client-properties were not set into the HttpMethod's HttpMethodParams. This meant that any custom retry handlers were ignored. This bug has now been rectified so that any property that starts with "http.method." is set into HttpMethodParams. As a result, custom retry handlers are now detected correctly.


Note You need to log in before you can comment on or make changes to this bug.