Bug 779825 - (SOA-2186) Wise SOAPClient fault behaviour is undocumented
Wise SOAPClient fault behaviour is undocumented
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Documentation, JBossESB (Show other bugs)
5.0.2
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.1.0 GA
Assigned To: David Le Sage
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 04:35 EDT by Jan Ypma
Modified: 2011-02-17 20:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
n/a (documentation issue)
Last Closed: 2011-01-31 23:42:48 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2186 Blocker Closed Wise SOAPClient fault behaviour is undocumented 2014-03-26 17:11:20 EDT

  None (edit)
Description Jan Ypma 2010-07-28 04:35:05 EDT
Affects: Documentation (Ref Guide, User Guide, etc.)
Complexity: High
Help Desk Ticket Reference: https://access.redhat.com/jbossnetwork/restricted/caseDetail.html?caseId=1178003
project_key: SOA

The documentation of the wise SOAPClient does not specify it's behaviour when the web service being called generates a SOAP fault. In actuality, the SOAPClient throws an ActionProcessingException with the SOAP fault as actual fault. This should at least be documented in the SOA-P programmers guide. It should also be mentioned that by default this error will not be returned when being called via SOAP ourselves (see below), and that there will be no redelivery when being called via JMS (since it's not a RuntimeException).

This default behaviour does cause problems when using the SOAPClient within an ESB-published web service endpoint itself. Apparently the "faultTo" EPR doesn't get set for exposed web service end points (which might be intended, or a different defect).

See https://access.redhat.com/jbossnetwork/restricted/caseDetail.html?caseId=1178003 for discussion.
Comment 1 Anne-Louise Tangring 2010-09-21 13:52:26 EDT
This is a candidate for SOA 5.1.0. not committed. Investigate if we need to provide better documentation on how fault handling works.
Comment 2 Jan Ypma 2010-09-22 08:13:29 EDT
I originally raised this issue, together with SOA-2188. Do let me know if/how I can help out with writing a bit of docs on the subject.
Comment 3 Kevin Conner 2010-09-22 08:25:06 EDT
The behaviour of exception processing should already be documented in the programmers' guide, this task would just defer to that part.
Comment 4 Anne-Louise Tangring 2010-12-06 11:26:19 EST
Usability and customer sat is important, thus this is made a blocker for SOA 5.1. 
Comment 5 Darrin Mison 2010-12-16 20:52:08 EST
Labels: Added: ESB_Programmers_Guide
Complexity: Added: High
Comment 7 Darrin Mison 2011-01-04 19:12:16 EST
Writer: Added: Darrin
Comment 8 Darrin Mison 2011-01-27 05:00:53 EST
this might have already been done upstream - please check
Comment 10 Darrin Mison 2011-02-17 06:54:21 EST
Writer: Removed: Darrin Added: dlesage
Comment 11 David Le Sage 2011-02-17 20:45:21 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/SOA-2186

The ESB Programmers' Guide documentation on exception processing behaviour has been updated to reflect that the SOAPClient throws an ActionProcessingException when a web service that is being called generates a SOAP fault. Note that redelivery doe not occurs when the web service is called through the JMS. This is because it is not a RuntimeException.
Comment 12 David Le Sage 2011-02-17 20:55:00 EST
Release Notes Text: Removed: https://issues.jboss.org/browse/SOA-2186

The ESB Programmers' Guide documentation on exception processing behaviour has been updated to reflect that the SOAPClient throws an ActionProcessingException when a web service that is being called generates a SOAP fault. Note that redelivery doe not occurs when the web service is called through the JMS. This is because it is not a RuntimeException. Added: https://issues.jboss.org/browse/SOA-2186

The ESB Programmers' Guide documentation on exception processing behaviour has been updated to reflect that the SOAPClient throws an ActionProcessingException when a web service that is being called generates a SOAP fault. Note that redelivery does not occurs when the web service is called through the JMS. This is because it is not a RuntimeException.
Comment 13 David Le Sage 2011-02-17 20:55:15 EST
Release Notes Text: Removed: https://issues.jboss.org/browse/SOA-2186

The ESB Programmers' Guide documentation on exception processing behaviour has been updated to reflect that the SOAPClient throws an ActionProcessingException when a web service that is being called generates a SOAP fault. Note that redelivery does not occurs when the web service is called through the JMS. This is because it is not a RuntimeException. Added: https://issues.jboss.org/browse/SOA-2186

The ESB Programmers' Guide documentation on exception processing behaviour has been updated to reflect that the SOAPClient throws an ActionProcessingException when a web service that is being called generates a SOAP fault. Note that redelivery does not occur when the web service is called through the JMS. This is because it is not a RuntimeException.
Comment 14 David Le Sage 2011-02-17 20:56:25 EST
Release Notes Text: Removed: https://issues.jboss.org/browse/SOA-2186

The ESB Programmers' Guide documentation on exception processing behaviour has been updated to reflect that the SOAPClient throws an ActionProcessingException when a web service that is being called generates a SOAP fault. Note that redelivery does not occur when the web service is called through the JMS. This is because it is not a RuntimeException. Added: https://issues.jboss.org/browse/SOA-2186

The ESB Programmers' Guide documentation on exception processing behaviour has been updated to reflect that the SOAPClient throws an ActionProcessingException when a web service that is being called generates a SOAP fault.

Note You need to log in before you can comment on or make changes to this bug.