Bug 77983 - Hardcoded path names in perl package
Hardcoded path names in perl package
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-16 12:23 EST by Eugene Kanter
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-28 03:30:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2002-11-16 12:23:34 EST
Description of Problem:  
 
Perl package does not support different %{_prefix} because there is a lot of 
hadcoded "/usr" strings in perl.spec and MANIFEST.* files. 
 
 
How Reproducible:  
 
always  
  
Steps to Reproduce:  
1.  redefine _prefix 
2.  try to build perl package. 
 
Additional information. 
 
%{....} macros should be used.
Comment 1 Warren Togami 2005-05-28 03:30:55 EDT
Sorry, we do not support relocatable packages.  If you want the package to be
relocatable please submit a spec patch for review against FC4.

Note You need to log in before you can comment on or make changes to this bug.