Bug 779845 - (SOA-2205) Classloading conflict between ModeShape and JBoss ESB on Lucene
Classloading conflict between ModeShape and JBoss ESB on Lucene
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Build Process, EDS (Show other bugs)
5.1.0.ER1
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.1.0 GA
Assigned To: trev
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-06 09:26 EDT by Jiri Pechanec
Modified: 2011-01-06 03:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Dev2 build with ModeShape deployed
Last Closed: 2011-01-06 03:02:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ms.log.gz (19.61 KB, application/x-gzip)
2010-08-06 09:44 EDT, Jiri Pechanec
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2205 None None None Never

  None (edit)
Description Jiri Pechanec 2010-08-06 09:26:00 EDT
project_key: SOA

Start the server
execute touch deploy/modeshape-services.jar/META-INF/jboss-beans.xml

The repository is undeployed
14:58:52,256 INFO  [ConnectionFactoryBindingService] Unbound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=ModeShapeDS' from JNDI name 'java:ModeShapeDS'
14:58:52,316 INFO  [JNDIManagedRepositories] Unbound ModeShape Repositories unbound from JNDI name "jcr/local"

After few seconds new deployment is in progress which fails with
14:59:15,758 ERROR [AbstractKernelController] Error installing to Start: name=ModeShapeEngine state=Create
java.lang.NoSuchFieldError: ANALYZED
        at org.modeshape.search.lucene.LuceneSearchEngine.<clinit>(LuceneSearchEngine.java:89)
        at org.modeshape.jcr.NodeTypeSchemata.<init>(NodeTypeSchemata.java:116)
        at org.modeshape.jcr.RepositoryNodeTypeManager.getRepositorySchemata(RepositoryNodeTypeManager.java:244)
        at org.modeshape.jcr.RepositoryQueryManager$SelfContained.<init>(RepositoryQueryManager.java:277)
        at org.modeshape.jcr.JcrRepository.<init>(JcrRepository.java:636)


ModeShape brings Lucene version 3.0. JBoss ESB in jbossesb.esb has Lucene version 2.0

From the error message it is obvious that after re-deployment the old Lucene version is used instead of correct one.

So there must be a classloading problem either in JBoss ESB or in ModeShape that causes leaking of the classes.
Comment 1 Kevin Conner 2010-08-06 09:31:51 EDT
Unlikely to be leaking of classes, more likely to be order of deployment.

Please attach a log file showing the complete sequence.

Kev
Comment 2 Jiri Pechanec 2010-08-06 09:44:18 EDT
Log attached, it shows successful start of ModeShape repo during server startup and then unsuccessful re-deployment.
Comment 3 Jiri Pechanec 2010-08-06 09:44:18 EDT
Attachment: Added: ms.log.gz
Comment 4 Jiri Pechanec 2010-08-06 09:56:31 EDT
I tried another experiment. I have started server first and then deployed modeshape-services.jar. The result was exactly same as with redeployment - so it seems that if ModeShape is (re-)deployed after JBoss ESB deployment then it fails.
Comment 5 Kevin Conner 2010-08-06 09:57:43 EDT
Looks like deployment ordering

modeshape before jbossesb means that 3.0 is used, jbossesb before modeshape (i.e. redeployment) means that 2.0 is used.

Are there other versions in the server, for example within seam?  If so, which versions?

Kev
Comment 6 Kevin Conner 2010-08-06 09:58:56 EDT
Our version of lucene only seems to exist to support a JCR message store, so changing may be straight forward.

Kev
Comment 7 Kevin Conner 2010-08-06 10:01:40 EDT
I can't find any source reference to lucene so we may even be able to remove it.

Kev
Comment 8 Jiri Pechanec 2010-08-06 10:08:20 EDT
Seam contains Lucene 2.4.1
Comment 9 Anne-Louise Tangring 2010-09-10 16:45:03 EDT
Candidate for SOA 5.1.0
Comment 10 Kevin Conner 2010-09-22 09:19:33 EDT
Link: Added: This issue is related to SOA-2206
Comment 11 trev 2010-11-25 09:52:08 EST
 If you want to use hsearch from seam 3.1.x it won't work with lucene 3. The  seam version of 2.4.1 comes in via hibernate search
Comment 12 trev 2010-11-25 11:34:42 EST
going to remove the esb version as part of the SOA build
Comment 13 Anne-Louise Tangring 2010-12-02 10:54:50 EST
Ken will create a new JIRA to handle Lucene - Seam incompatabilities
Comment 14 trev 2010-12-03 08:55:15 EST
esb/build.xml
esb/post-patch/remove_unneeded_jar.xml
Committed revision 7507
Comment 16 Darrin Mison 2011-01-04 19:08:22 EST
Writer: Added: Darrin
Comment 17 Jiri Pechanec 2011-01-06 03:02:34 EST
Verified in ER6

Note You need to log in before you can comment on or make changes to this bug.