Bug 779846 - (SOA-2206) JackRabbit is shipped with SOA-P
JackRabbit is shipped with SOA-P
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Configuration (Show other bugs)
5.1.0.ER1
Unspecified Unspecified
high Severity high
: ---
: 5.1.0 GA,5.1.0.ER7
Assigned To: trev
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-06 09:29 EDT by Jiri Pechanec
Modified: 2011-08-11 06:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-11 00:10:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2206 Major Closed JackRabbit is shipped with SOA-P 2013-07-09 02:19:32 EDT

  None (edit)
Description Jiri Pechanec 2010-08-06 09:29:14 EDT
project_key: SOA

SOA-P is shipped with JackRabbit and JCR 1.0 API - present in jbossesb.esb/lib dir. Should not it be replaced with ModeShape? Is the use-case for which JackRabbit is used (Message Store) supported? I think it is not.
Should it be supported with ModeShape?
Comment 1 Kevin Conner 2010-08-06 11:01:43 EDT
This is the same issue as SOA-2205, shipping a JCR implementation for our JCRMessageStoreImpl.
Comment 2 Anne-Louise Tangring 2010-09-22 08:56:42 EDT
Candidate for SOA 5.1.0
Comment 4 Kevin Conner 2010-09-22 09:19:33 EDT
Link: Added: This issue related SOA-2205
Comment 5 Jiri Pechanec 2010-09-22 09:41:43 EDT
It is there since 4.2 coming from JBossESB, it was never supported.
Comment 6 Kevin Conner 2010-09-22 09:47:14 EDT
The only references within the ESB are direct (but internal) through the JCRMessageStore and indirect through jBPM.

Both uses are as alternatives to providing a JCR implementation via JNDI.

We have never supported JCRMesageStore nor, to my knowledge, the jBPM usage through the platform.
Comment 7 trev 2010-12-06 10:40:31 EST
removed as it is not supported
Committed revision 7536.
Comment 9 Darrin Mison 2011-01-04 19:14:39 EST
Writer: Added: dlesage
Comment 10 Jiri Pechanec 2011-01-06 02:55:15 EST
JCR 1.0 API is still present but Modeshape installs JCR 2.0 API in lib dir. Can't this lead to conflicts?
Comment 11 trev 2011-01-12 10:12:03 EST
added jcr-1.0.jar to the delete list Committed revision 7889.
Comment 12 Jiri Pechanec 2011-01-25 08:35:00 EST
Verified in ER7
Comment 13 David Le Sage 2011-02-11 00:06:46 EST
Temporarily reopening to update release note info.
Comment 14 David Le Sage 2011-02-11 00:08:42 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/SOA-2206

The SOA Platform shipped with JackRabbit and JCR 1.0 API. As these are unsupported, they have been removed.
Comment 15 David Le Sage 2011-02-11 00:10:07 EST
Release Notes Text: Removed: https://issues.jboss.org/browse/SOA-2206

The SOA Platform shipped with JackRabbit and JCR 1.0 API. As these are unsupported, they have been removed. Added: https://issues.jboss.org/browse/SOA-2206

The SOA Platform shipped with JackRabbit and JCR 1.0 API. As these are unsupported on this platform, they have been removed.
Comment 16 Martin Weiler 2011-08-11 06:27:21 EDT
Link: Added: This issue relates to SOA-3261

Note You need to log in before you can comment on or make changes to this bug.