Bug 779854 - (SOA-2214) Service Invoker load balance policy that prefers local EPRs
Service Invoker load balance policy that prefers local EPRs
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.2
Unspecified Unspecified
high Severity high
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 11:11 EDT by niklas käck
Modified: 2011-01-04 01:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-07 08:05:25 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2214 None Closed Service Invoker load balance policy that prefers local EPRs 2012-05-17 14:31:09 EDT

  None (edit)
Description niklas käck 2010-08-09 11:11:32 EDT
Help Desk Ticket Reference: https://support.redhat.com/jbossnetwork/restricted/caseDetail.html?caseId=352029
project_key: SOA

When running SOA-P in a clustered UDDI setup, a request may be routed according to three load balance algorithms (AFAIK).
* First Available
* Round Robin
* Random Robin

There's no balancer that takes into account that a user might not want the requests to get balanced between the instances in the cluster (since that makes it hard to debug in the event of a failure)

This feature request is for a load balance policy for the service invoker that prefers the local instance over other remote instances to avoid having the request jumping between instances.
Comment 1 Kevin Conner 2010-08-09 11:12:19 EDT
Link: Added: This issue is related to SOA-1529
Comment 2 Kevin Conner 2010-08-09 11:13:36 EDT
Link: Added: This issue depends JBESB-3449
Comment 3 Anne-Louise Tangring 2010-09-10 14:43:21 EDT
This is a candidate for SOA 5.1.0
Comment 4 Laura Bailey 2010-12-16 19:34:29 EST
Writer: Added: dlesage
Comment 5 Laura Bailey 2010-12-16 19:54:31 EST
Release Notes Docs Status: Added: Documented as Known Issue

Note You need to log in before you can comment on or make changes to this bug.