Bug 779855 - (SOA-2215) Aggregator meta data in properties
Aggregator meta data in properties
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Unspecified
high Severity high
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
: SOA-2223 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 11:23 EDT by Stelios Koussouris
Modified: 2011-02-11 00:03 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-11 00:03:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2215 None None None Never

  None (edit)
Description Stelios Koussouris 2010-08-09 11:23:15 EDT
Affects: Documentation (Ref Guide, User Guide, etc.), Interactive Demo/Tutorial
Help Desk Ticket Reference: https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=864653&gid=1354
project_key: SOA

------------------------------------------------------------------------------------------------------------------------------------
The MessageMulticaster creates an aggregation id and stores this value in message properties. Normally this does not prove to be an issue but when using invm transport it may cause issues.

When the message is sent to multiple services, using pass by reference semantics, then all services will see the *same* properties and may, depending on timing, see the same aggregation id.

The aggregation value should really be in the message context as this section is always duplicated when creating a reference, never shared. The problem we face is that users may already be referencing the property, especially if they are creating a fresh response message, so we need to think about handling this.
------------------------------------------------------------------------------------------------------------------------------------
Comment 1 Kevin Conner 2010-08-09 11:25:51 EDT
Link: Added: This issue depends JBESB-3309
Comment 2 Kevin Conner 2010-08-09 11:26:16 EDT
Link: Added: This issue is related to SOA-2088
Comment 3 Kevin Conner 2010-08-10 12:24:50 EDT
Link: Added: This issue related SOA-2223
Comment 4 Laura Bailey 2010-12-16 19:34:30 EST
Writer: Added: dlesage
Comment 5 Laura Bailey 2010-12-16 19:38:31 EST
Release Notes Docs Status: Added: Not Yet Documented
Comment 7 Kevin Conner 2011-02-08 18:01:49 EST
Link: Added: This issue is duplicated by SOA-2223
Comment 8 David Le Sage 2011-02-10 23:59:25 EST
Temporarily reopening to update release note info.
Comment 9 David Le Sage 2011-02-11 00:03:20 EST
Release Notes Docs Status: Removed: Not Yet Documented Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/JBESB-3309

The MessageMulticaster created an aggregation identifier and stored this value in message properties. This caused problems when used in conjunction with the InVM transport because, when it was sent to multiple services all services would see the same properties and, depending on timing, potentially see the same aggregation identifier. To fix this problem, aggregation value is now stored in the message context as this section is always duplicated, rather than shared, when a reference is created. 


Note You need to log in before you can comment on or make changes to this bug.