Bug 77986 - Installing RH Linux 8.0 failed
Installing RH Linux 8.0 failed
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-16 13:37 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 05:16:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error dump (64.16 KB, text/plain)
2002-11-16 13:39 EST, Need Real Name
no flags Details
Output from "lspci -vvn" command (3.14 KB, text/plain)
2002-11-25 17:50 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-11-16 13:37:30 EST
Description of Problem:
The installation failed half way through and asked to save a log file to floppy 
which I did. On reboot, and trying the installation again, I get a 'reading 
header - cpio failed' message and am unable to proceed with the installation.

How Reproducible:
On every reboot.

Steps to Reproduce:
1. Disk 1 of 3 in CD-ROM.
2. Press enter when initial installation screen appears.
3. Installation bombs out and last message is 'You can safely reboot your 
system'.

Actual Results:


Expected Results:


Additional Information:
Comment 1 Need Real Name 2002-11-16 13:39:14 EST
Created attachment 85325 [details]
Error dump
Comment 2 Charmaine Tan 2002-11-17 15:04:38 EST
i'd also like to know how 2 solve this problem...?
Comment 3 Need Real Name 2002-11-19 04:13:21 EST
The problem resolved itself when I appended MEM=32M to the boot option. 
However, after finishing the installation there was a CRC error on booting 
using GRUB. I appended mem=64m to the kernel option and Linux came up without a 
hitch.  I assume that Linux will only be accessing 64MB of RAM. Any ideas how I 
can use the whole 128MB on my machine?  I've tried booting with the command 
mem=96m but the CRC error reoccurs.
Comment 4 Michael Fulbright 2002-11-19 13:48:55 EST
What chipset is your motherboard basde on?
Comment 5 Need Real Name 2002-11-20 20:35:30 EST
The machine is a HP Vectra VL with a Pentium II processor.
Comment 6 Arjan van de Ven 2002-11-22 10:32:35 EST
what video card is that ?
(it can be that you have a video card that "shares" (eg steals) ram and that
seems to get misdetected)
Comment 7 Need Real Name 2002-11-23 07:31:12 EST
The video card is a Cirrus Logic GDS 465
Comment 8 Need Real Name 2002-11-23 07:53:38 EST
Sorry misread it. It actually is a Cirrus Logic GD5465
Comment 9 Mike A. Harris 2002-11-25 07:41:10 EST
This seems much more like bad media to me.  Is this an official boxed set
installation of Red Hat Linux, or is it a downloaded copy?  Either way,
try booting the install CD, with "linux mediacheck" to test your CDR
media prior to installation.  In particular the "cpio read failed" error
seems very indicative to me of bad media.
Comment 10 Need Real Name 2002-11-25 07:55:25 EST
It is an official boxed set. No need to worry about the install since 
installation worked fine once I had appended mem=32M to the boot option. 
However, in order for GRUB to load the kernel, I need to append mem=64M as an 
option. This is inconvenient since the machine has 128M of RAM and is running 
painfully slowly, presumably because it is only accessing 64M of RAM.
Comment 11 Mike A. Harris 2002-11-25 08:00:04 EST
Ok, even though this is a boxed set, booting with the mediacheck is
recommended.  Although very unlikely, it is possible that your media
is defective.  Testing it is the best recourse.

If the testing succeeds:

Does a text mode installation work?  Boot with "linux text" to try a
text mode install.
Comment 12 Need Real Name 2002-11-25 08:17:08 EST
Text mode installation HAS worked. RedHat Linux using GNOME or KDE is working 
fine. What is not working is using Linux without restricting the memory to 
64MB. Surely if the install has worked fine, the subsequent memory problem is 
not going to be due to corrupted media?
Comment 13 Mike A. Harris 2002-11-25 09:04:48 EST
That sounds correct.  Sounds to me like a kernel issue of some kind,
or a hardware issue.

Can you provide the complete output of "lspci -vvn" also?
Comment 14 Need Real Name 2002-11-25 17:50:12 EST
Created attachment 86410 [details]
Output from "lspci -vvn" command
Comment 15 Need Real Name 2002-12-19 05:16:25 EST
I replaced the 128MB ram chip with 256MB ram and it solved the problem. What I 
don't know is whether the problem was with the actual memory chip or the size 
of memory (can't think why it would be this). Unfortunately I don't have 
another 128MB chip to find out which!

Note You need to log in before you can comment on or make changes to this bug.