Bug 779864 - (SOA-2223) Aggregator meta data in properties
Aggregator meta data in properties
Status: CLOSED DUPLICATE of bug 779855
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 12:24 EDT by Stelios Koussouris
Modified: 2011-02-08 18:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-08 18:02:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2223 None None None Never

  None (edit)
Description Stelios Koussouris 2010-08-10 12:24:10 EDT
Affects: Interactive Demo/Tutorial, Documentation (Ref Guide, User Guide, etc.)
Help Desk Ticket Reference: https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=864653&gid=1354
project_key: SOA

------------------------------------------------------------------------------------------------------------------------------------
The MessageMulticaster creates an aggregation id and stores this value in message properties. Normally this does not prove to be an issue but when using invm transport it may cause issues.

When the message is sent to multiple services, using pass by reference semantics, then all services will see the *same* properties and may, depending on timing, see the same aggregation id.

The aggregation value should really be in the message context as this section is always duplicated when creating a reference, never shared. The problem we face is that users may already be referencing the property, especially if they are creating a fresh response message, so we need to think about handling this.
------------------------------------------------------------------------------------------------------------------------------------
Comment 1 Kevin Conner 2010-08-10 12:24:50 EDT
Link: Added: This issue is related to SOA-2215
Comment 2 Kevin Conner 2010-08-10 12:25:54 EDT
Link: Added: This issue depends JBESB-3310
Comment 3 Kevin Conner 2010-08-10 12:36:10 EDT
Link: Added: This issue is incorporated by SOA-2210
Comment 4 Kevin Conner 2010-08-17 12:48:29 EDT
Link: Added: This issue depends JBESB-3464
Comment 5 Laura Bailey 2010-12-16 19:41:33 EST
Writer: Added: Darrin
Comment 6 Laura Bailey 2010-12-16 19:47:57 EST
Release Notes Docs Status: Added: Not Yet Documented
Comment 8 Kevin Conner 2011-02-08 18:01:49 EST
This is now a duplicate of SOA-2215
Comment 9 Kevin Conner 2011-02-08 18:01:49 EST
Link: Added: This issue duplicates SOA-2215

Note You need to log in before you can comment on or make changes to this bug.