This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 779952 - (SOA-2312) Message Loss or premature execution termination in an action during shutdown
Message Loss or premature execution termination in an action during shutdown
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.2
Unspecified Unspecified
high Severity high
: ---
: 5.1.0.ER2
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-13 09:02 EDT by Kevin Conner
Modified: 2011-02-25 01:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-25 01:04:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2312 None None None Never

  None (edit)
Description Kevin Conner 2010-09-13 09:02:15 EDT
project_key: SOA
Comment 1 Kevin Conner 2010-09-13 09:02:43 EDT
Link: Added: This issue depends JBESB-3473
Comment 2 Kevin Conner 2010-09-13 09:31:58 EDT
Updated in ESB codebase, will be in next tag for platform.
Comment 3 David Le Sage 2011-02-25 01:00:09 EST
Temporarily reopening to update release note info.
Comment 4 David Le Sage 2011-02-25 01:04:38 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/JBESB-3473

JMS messages could be lost and actions could be terminated prematurely during shut down. This was because  when the doStop method was called it set the state to STOPPING and immediately terminated the executor thread (MessageAwareListener.java) irrespective of whether the thread was processing anything or not.  To fix this problem, a change has been made to the MessageAwareListener code. As a result, messages will not be lost when the software is shutting down.

Note You need to log in before you can comment on or make changes to this bug.