Bug 780146 - (SOA-2519) "host paramter is null' reported when attempting WS proxying
"host paramter is null' reported when attempting WS proxying
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Documentation, JBossESB (Show other bugs)
5.1.0.ER3
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.1.0 GA
Assigned To: David Le Sage
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-29 12:10 EDT by John Doyle
Modified: 2011-03-03 22:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
5.0.1.ER3, RHEL 5, JBDS Beta 1
Last Closed: 2011-03-03 22:42:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
SOA-2519-jira.zip (3.50 KB, application/x-zip)
2010-10-29 12:11 EDT, John Doyle
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2519 None None None Never

  None (edit)
Description John Doyle 2010-10-29 12:10:07 EDT
project_key: SOA

I'm attempting to proxy a Teiid SOAP service hosted in the same SOA install.  When deploying the ESB project I get the following error when the ESB tries to load the WSDL.  I've debugged it partially are it appears that the host never gets into the HTTP Method even though the correct URL is supplied.  This should be reproducible w/o my SOAP service.

Caused by: org.jboss.soa.esb.ConfigurationException: java.lang.IllegalArgumentException: host parameter is null
	at org.jboss.soa.esb.actions.soap.proxy.SOAPProxy.<init>(SOAPProxy.java:193)
	... 66 more
Caused by: java.lang.IllegalArgumentException: host parameter is null
	at org.apache.commons.httpclient.HttpConnection.<init>(HttpConnection.java:205)
	at org.apache.commons.httpclient.HttpConnection.<init>(HttpConnection.java:154)
	at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionWithReference.<init>(MultiThreadedHttpConnectionManager.java:1105)
	at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$ConnectionPool.createConnection(MultiThreadedHttpConnectionManager.java:741)
	at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager.doGetConnection(MultiThreadedHttpConnectionManager.java:469)
	at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager.getConnectionWithTimeout(MultiThreadedHttpConnectionManager.java:394)
	at org.jboss.soa.esb.http.ESBMultiThreadedHttpConnectionManager.getConnectionWithTimeout(ESBMultiThreadedHttpConnectionManager.java:74)
	at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:152)
	at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:396)
	at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:324)
	at org.jboss.soa.esb.actions.soap.RemoteWsdlLoader.load(RemoteWsdlLoader.java:90)
	at org.jboss.soa.esb.actions.soap.AbstractWsdlContractPublisher.getWsdl(AbstractWsdlContractPublisher.java:199)
	at org.jboss.soa.esb.actions.soap.proxy.SOAPProxyWsdlLoader$Puller.pull(SOAPProxyWsdlLoader.java:521)
	at org.jboss.soa.esb.actions.soap.proxy.SOAPProxyWsdlLoader.load(SOAPProxyWsdlLoader.java:157)
	at org.jboss.soa.esb.actions.soap.proxy.SOAPProxy.<init>(SOAPProxy.java:188)
	... 66 more
12:01:57,726 INFO  [EsbDeployment] Destroying 'ProductProxy.esb'
Comment 1 John Doyle 2010-10-29 12:11:17 EDT
Here's the project.
Comment 2 John Doyle 2010-10-29 12:11:17 EDT
Attachment: Added: SOA-2519-jira.zip
Comment 3 Kevin Conner 2010-11-01 12:32:34 EDT
You removed HttpProtocol from the list of configurators.

configurators=AuthBASIC, HttpProtocol

Is this not mentioned in the documentation?
Comment 4 John Doyle 2010-11-02 11:32:06 EDT
Here is the doc I've been referring to, and if I'm reading it correctly, that's an optional property.

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Enterprise_SOA_Platform/5/html/ESB_Programmers_Guide/chap-SOA_ESB_Programmers_Guide-Out-of-the-box_Actions.html#sect-SOAP-SOAPPROXY

Is my understanding incorrect?

For the service I have configured, I need to send Basic credentials, and it looks like I was using the clientCredentialRequired property incorrectly.  I've change that value to be false, but it doesn't seem to matter.
Comment 5 Kevin Conner 2010-11-02 11:48:21 EDT
The exception you are seeing is caused by the fact you have not configured the HttpProtocol.

While this property is optional, defaulting to HttpProtocol, you must include that configurator (or an alternative) if you specify it.

The documentation does include both but is not as clear as it should be.
Comment 6 John Doyle 2010-11-05 15:51:51 EDT
I just spoke to Ken Johnson following the defect review and we discussed what the doc might say.  One issue that it's struggled with in this case is how to set up the HTTP config for different scenarios.  All of our examples seem to point to a SSL Socket implementation sample.  I think we should document the SSL config, as well as a plain HTTP config and a plain HTTP config with BASIC Auth.  
Comment 7 Kevin Conner 2010-11-06 04:19:40 EDT
The documentation that appears to be missing is the descriptions of each configurator and what they do, including whether they are required or optional.

If we have this in place then the configuration should be clearer.
Comment 8 Anne-Louise Tangring 2010-11-09 10:54:52 EST
Candidate for SOA 5.1.0. Needs clearer documentation.
Comment 9 Anne-Louise Tangring 2010-12-06 11:52:08 EST
Blocker for SOA 5.1.0
Comment 11 Darrin Mison 2011-01-04 19:14:45 EST
Writer: Added: dlesage
Comment 12 Kevin Conner 2011-03-03 08:55:17 EST
Link: Added: This issue depends JBESB-3575
Comment 13 Kevin Conner 2011-03-03 08:57:54 EST
Updated in ESB 4.9CP branch
Comment 14 David Le Sage 2011-03-03 22:41:51 EST
Section has been merged from upstream into product document.
Comment 15 David Le Sage 2011-03-03 22:41:51 EST
Release Notes Docs Status: Added: Not Required

Note You need to log in before you can comment on or make changes to this bug.