Bug 78025 - Default ntp.conf does not work
Default ntp.conf does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-17 17:22 EST by Need Real Name
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-21 22:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-11-17 17:22:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I have been unable to have ntpd sync with a nearby server using the defaults in 
ntp.conf on two separate machines running 8.0.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. redhat-config-date
2. choose remote time server and enable.
3.
	

Actual Results:  Using ntpq -p the reach value for the server remains 0.  The 
LOCAL server gets the star.

Expected Results:  Reach value for server should step up to 377 and it should 
be selected for synchronization.

Additional info:

Through trial and error I have found that changing the line
restrict default ignore
  to
restrict default nomodify notrap noquery
at the top of ntp.conf allows synchronization with a remote server to occur.
Comment 1 Jon DeSena 2002-11-18 13:44:18 EST
I have a laptop, which since installing RH8, has a significantly slow clock
(another bug perhaps?). I was trying to use ntp to keep the time proper, at
least while plugged into a network, but no matter what, ntpd did not synchronize
at all. The ntpdate command would work, but it would drift from there such that
after a day of uptime, the clock would be half an hour behind, even with ntp
running. After following the hint above (using "restrict default nomodify notrap
noquery") ntpd keeps the clock synchronized. Therefore, I confirm both
jaco_botha's problem, and his fix.
Comment 2 Ken Snider 2002-11-18 14:35:04 EST
I can verify this fact. This is also true of RedHat 7.3
Comment 3 Harald Hoyer 2002-11-19 06:21:22 EST
I only allow connections to and from my time servers..
from ntpd.conf, modified for my needs...
....
# --- OUR TIMESERVERS -----
# or remove the default restrict line
# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.

restrict 172.16.2.2 mask 255.255.255.255 nomodify notrap noquery
server 172.16.2.2
...

Comment 4 Need Real Name 2002-11-19 09:38:26 EST
WHAT????

First of all, harald, I don't understand a word you are saying.  What does 
modifying your ntpd.conf file for your needs have to do with the fact that the 
Red Hat supplied file and configuration tool does not work?
Secondly, how can you just close this report saying it is not a bug?  Again, 
the Red Hat supplied configuration file does not work, and using the Red Hat 
supplied configuration tool does not make it work either.  Two other people 
confirmed my report within a day.  What about the hundreds of other people who 
have similar problems but have not said anything because they haven't found a 
bug in bugzilla on this topic yet?

I am shocked!!!!
Comment 5 Harald Hoyer 2002-11-19 09:54:55 EST
oops, did overread, that you used redhat-config-date... otherwise, I would say:
"User configuration error"
assigning to right component... sorry..
Comment 6 Harald Hoyer 2002-11-19 09:58:25 EST
btw, you have to _edit_ ntpd.conf to fit it to your needs!
I am not responsible, if someone can control your ntpd due to misconfiguration.
You can test security by using ntpdc.
$ /usr/sbin/ntpdc myhost
then you may be able to add other peers or remove them..
Comment 7 Need Real Name 2002-11-19 10:25:27 EST
Apology accepted.  I could've been more explicit about the redhat-config-date.
Comment 8 Need Real Name 2002-11-19 18:15:44 EST
Edit ntpd.conf?  This bug is about ntp.conf isn't it?
Comment 9 Brent Fox 2002-11-22 14:21:48 EST
I must admit that I am unable to tell what this report is truly about.  The
default ntp.conf file seems to work for me and many other users once you use
redhat-config-date to select an NTP server.  
Comment 10 Need Real Name 2002-11-22 18:31:53 EST
This bug is about ntp not working when choosing any of the timeservers from the 
list in redhat-config-date or typing in the name of another timeserver.  The 
only way I have found to make it work is to change the line 
  restrict default ignore 
    to
  restrict default nomodify notrap noquery.

This is 100% repeatable for me and I suppose for the two other people who 
posted their comments as well.

I also tried with redhat-config-date-1.5.5-1 from Rawhide.  Same result.
Comment 11 Alessandro Polverini 2002-11-26 15:57:11 EST
I would like to add my experience: ntpd synchronization with time servers does
_not_ work in Redhat 7.3 and 8.0 with default configuration and time servers
chosen with redhat-config-date.
I'll try with the options "nomodify notrap noquery" and test if the behaviour
changes.
Ntpd worked fine in redhat 7.1.

Thanks,
Alex
Comment 12 Mike Chambers 2002-12-29 09:24:56 EST
I didn't use redhat-config-date to set my time servers.  I used 3 others from 
the public time server list web site, and mine wouldn't sync up either.  I 
added a restrict line for each server I wanted to use and then it was able to 
sync up, and allow my internal machine(s) to sync up to it as well.

example..

restrict 1.2.3.4
restrict 1.2.3.5
restrict 1.2.3.6

Then below that is..

server 1.2.3.4
server 1.2.3.5
server 1.2.3.6
Comment 13 Brent Fox 2003-01-14 00:24:52 EST
I've made redhat-config-date-1.5.7-3 (in Rawhide) write the IP of the NTP server
to the 'restrict' line and the domain name to the 'server' line.  Please try
with this version and reopen if this doesn't fix the problem. 
Comment 14 Need Real Name 2003-01-14 09:22:59 EST
I'm currently using redhat-config-date-1.5.7-1 from Rawhide 1/3/2003 and that 
works fine, thanks!  I believe -3 is essentially the same?  
Comment 15 Brent Fox 2003-01-31 16:42:18 EST
Yeah, I think -3 fixed some other unrelated problems.

Note You need to log in before you can comment on or make changes to this bug.