Bug 78028 - building gnome-panel rpm fails
Summary: building gnome-panel rpm fails
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-17 22:51 UTC by Bernd Kischnick
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-17 22:55:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for the spec file (1.66 KB, patch)
2002-11-17 22:55 UTC, Bernd Kischnick
no flags Details | Diff

Description Bernd Kischnick 2002-11-17 22:51:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:0.9.8) Gecko/20020310

Description of problem:
You can't build a binary RPM from the source RPM, unless there is an old binary
version of the same RPM already installed on the build host.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
rpm -e gnome-panel
rpm -ivh gnome-panel-2.0.6-9.src.rpm
rpmbuild -bb SPECS/gnome-panel.spec

Actual Results:  error building system-tray-applet.

Expected Results:  binary rpm should be built.

Additional info:

A build of the system-tray-applet uses pkgconfig to find libpanel-applet. But
libpanel-applet has only just been built, but not installed, so pkgconfig can
only find an older version of the same package, if there is one.

The attached patch for the specfile uses a modified pkgconfig-".pc"-file that
points to the freshly built version of libpanel-applet.

Comment 1 Bernd Kischnick 2002-11-17 22:55:30 UTC
Created attachment 85368 [details]
patch for the spec file

Comment 2 Havoc Pennington 2002-11-17 23:01:49 UTC
Thanks for the patch. This issue goes away in the latest packages, though 
(not yet in Rawhide but will be shortly) because gnome-panel 2.1.x just includes
the applet in the main panel package. So I think I'll let things naturally fix
themselves that way.


Note You need to log in before you can comment on or make changes to this bug.