Bug 780438 - (SOA-2871) QS monitoring_action does not report passed messages correctly
QS monitoring_action does not report passed messages correctly
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, Examples (Show other bugs)
5.1.0.ER9
Unspecified Unspecified
high Severity high
: ---
: 5.2.0.ER3
Assigned To: tcunning
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-04 08:31 EST by mvanek
Modified: 2013-03-13 00:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-12 03:45:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBESB-3602 None None None Never
JBoss Issue Tracker SOA-2871 None None None Never

  None (edit)
Description mvanek 2011-02-04 08:31:36 EST
project_key: SOA

Three messages (numbers 3,14,23) are sent to MVELMonitoringAction that is set to report messages satisfying condition >5. As the result messages 14 and 23 should be stored in mbean as described in the readme file, but what is stored there is a duplicate of the last message, 23. The number of stored messages is correct (verified with more messages), but all the messages are duplicates of the last one passed.
Comment 1 Kevin Conner 2011-02-04 08:53:43 EST
There are a number of concurrency issues in MVELMonitoringAction/MVELMonitor/MonitoringPatternBean but this particular issue is caused by the reuse of the MonitoringPatternBean which contains the message value.  All entries in the list refer to the same instance.
Comment 2 tcunning 2011-04-12 16:07:09 EDT
Link: Added: This issue relates to JBESB-3602
Comment 3 tcunning 2011-04-18 14:19:35 EDT
Fixed in ESB project.

tcunning@localhost:product]$ svn commit
Sending        product/rosetta/src/org/jboss/soa/esb/actions/monitoring/MVELMonitor.java
Sending        product/rosetta/src/org/jboss/soa/esb/actions/monitoring/MVELMonitoringAction.java
Transmitting file data ..
Committed revision 36947.
Comment 4 David Le Sage 2011-09-02 01:45:13 EDT
Release Notes Docs Status: Added: Documented as Resolved Issue
Writer: Added: dlesage
Release Notes Text: Added: https://issues.jboss.org/browse/SOA-2871

The MVELMonitoringAction was storing the correct number of messages but each of them was just a duplicate of the very last message passed.  This bug was caused by the reuse of the MonitoringPatternBean (which contains the message value) and which resulted in every enty in the list referring to the same instance. A code fix has been applied and, as a result, the messages are now stored correctly.
Comment 5 Marek Baluch 2011-10-12 03:45:48 EDT
Verified in SOA 5.2 ER4.

Note You need to log in before you can comment on or make changes to this bug.