Bug 780503 - (SOA-2931) EBWS incompatible with SOAPProxy
EBWS incompatible with SOAPProxy
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.2
Unspecified Unspecified
medium Severity medium
: ---
: 5.2.0 GA
Assigned To: Len DiMaggio
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-21 14:37 EST by Rick Wagner
Modified: 2011-11-01 13:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Any supporting ESB
Last Closed: 2011-11-01 13:34:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBESB-3573 Minor Open EBWS incompatible with SOAPProxy 2013-01-23 09:53:38 EST
JBoss Issue Tracker SOA-2931 Minor Closed EBWS incompatible with SOAPProxy 2013-01-23 09:53:37 EST

  None (edit)
Description Rick Wagner 2011-02-21 14:37:09 EST
Affects: Documentation (Ref Guide, User Guide, etc.)
Help Desk Ticket Reference: https://c.na7.visual.force.com/apex/Case_View?id=500A0000006GiMq&sfdc.override=1
Steps to Reproduce: The problem is very easy to reproduce.  Start with the webservice_proxy_basic quickstart, then add the text that follows.  You'll find that you can toggle either service on or off and run one service at a time.  If you try to un-comment both, you'll get the above error at deploy time.



- To jboss-esb.xml:
<!--
  <service category="test" description="test" invmScope="GLOBAL" name="test">
   <actions  inXsd="/request.xsd"
    mep="RequestResponse" outXsd="/request.xsd" webservice="true">
    <action class="org.jboss.soa.esb.actions.SystemPrintln" name="log">
     <property name="message" value="test"/>
    </action>
   </actions>
  </service>
-->


To root of deployment (request.xsd):
<xs:schema version="1.0" targetNamespace="http://www.jboss.org/sayHi" xmlns:x1="http://www.jboss.org/sayHi"  xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified">
<xs:element name="sayHi" type="x1:sayHi"/>
<xs:complexType name="sayHi">
<xs:sequence>
 <xs:element name="arg0" type="xs:string" minOccurs="1"/>
</xs:sequence>
</xs:complexType>
</xs:schema>




Workaround: Workaround Exists
Workaround Description: Don't deploy the two service types in the same deployment.
project_key: SOA

When configuring an .esb, it appears the user cannot have both an EBWS and SOAPProxy. You can use either-- commenting out the compliment-- and it will work.  When both are uncommented, the user gets the following error at deployment time:

--------------------------------------------------------------------------------------------------------------------------------------
 Deployment "jboss.esb.vfszip:/path_to_deployment/Quickstart_webservice_proxy_basic.esb/" is in error due to the following reason(s): java.lang.UnsupportedOperationException
---------------------------------------------------------------------------------------------------------------------------------------
Comment 1 Rick Wagner 2011-02-21 14:50:06 EST
Link: Added: This issue duplicates JBESB-3573
Comment 2 Rick Wagner 2011-02-21 14:50:56 EST
Link: Added: This issue related JBESB-3573
Comment 3 Rick Wagner 2011-02-21 14:53:08 EST
Link: Added: This issue is related to JBESB-3573
Comment 4 Rick Wagner 2011-02-21 14:56:05 EST
Link: Added: This issue Cloned to SOA-2932
Comment 5 Kevin Conner 2011-02-28 07:12:15 EST
The EsbWebServiceDeployer creates a list of publishers which is used to initialise the publishers property in the EsbDeployment, via EsbDeployer and EsbMetaData.

Unfortunately EsbMetaData returns an unmodifiable list which Configuration.create attempts to modify.

java.lang.RuntimeException: java.lang.UnsupportedOperationException
	at org.jboss.soa.esb.listeners.config.Configuration.create(Configuration.java:185)
	at org.jboss.soa.esb.listeners.deployers.mc.EsbDeployment.start(EsbDeployment.java:124)

This is not present in 5.1.0 as the MC deployer integration was rewritten.
Comment 6 tcunning 2011-04-06 15:51:14 EDT
This was committed in 4.9 and should be in the merge, please test with SOA 5.2
Comment 7 David Le Sage 2011-09-02 00:35:37 EDT
Release Notes Docs Status: Added: Documented as Resolved Issue
Writer: Added: dlesage
Release Notes Text: Added: https://issues.jboss.org/browse/SOA-2931

User could not have both EBWS and SOAPProxy deployment types on the same deployment. This was because the EsbWebServiceDeployer created a list of publishers which was used to initialise the publishers property in the EsbDeployment, via EsbDeployer and EsbMetaData. Unfortunately EsbMetaData returned an unmodifiable list which Configuration.create nevertheless attempted to modify leading to a java.lang.UnsupportedOperationException. The code has now been changed and, as a result, users can now have two different deployment types on the same deployment.
Comment 8 Len DiMaggio 2011-11-01 13:34:19 EDT
Verified with SOA-P 5.2.0.ER6

Note You need to log in before you can comment on or make changes to this bug.