Bug 780504 - (SOA-2932) EBWS incompatible with SOAPProxy - Clone for 5.1.x
EBWS incompatible with SOAPProxy - Clone for 5.1.x
Status: CLOSED NOTABUG
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.1.0 GA
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Default User
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-21 14:56 EST by Rick Wagner
Modified: 2011-02-28 07:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Any supporting ESB
Last Closed: 2011-02-28 07:07:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBESB-3573 None None None Never
JBoss Issue Tracker SOA-2932 None None None Never

  None (edit)
Description Rick Wagner 2011-02-21 14:56:02 EST
Affects: Documentation (Ref Guide, User Guide, etc.)
Help Desk Ticket Reference: https://c.na7.visual.force.com/apex/Case_View?id=500A0000006GiMq&sfdc.override=1
Steps to Reproduce: The problem is very easy to reproduce.  Start with the webservice_proxy_basic quickstart, then add the text that follows.  You'll find that you can toggle either service on or off and run one service at a time.  If you try to un-comment both, you'll get the above error at deploy time.



- To jboss-esb.xml:
<!--
  <service category="test" description="test" invmScope="GLOBAL" name="test">
   <actions  inXsd="/request.xsd"
    mep="RequestResponse" outXsd="/request.xsd" webservice="true">
    <action class="org.jboss.soa.esb.actions.SystemPrintln" name="log">
     <property name="message" value="test"/>
    </action>
   </actions>
  </service>
-->


To root of deployment (request.xsd):
<xs:schema version="1.0" targetNamespace="http://www.jboss.org/sayHi" xmlns:x1="http://www.jboss.org/sayHi"  xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified">
<xs:element name="sayHi" type="x1:sayHi"/>
<xs:complexType name="sayHi">
<xs:sequence>
 <xs:element name="arg0" type="xs:string" minOccurs="1"/>
</xs:sequence>
</xs:complexType>
</xs:schema>




Workaround: Workaround Exists
Workaround Description: Don't deploy the two service types in the same deployment.
project_key: SOA

When configuring an .esb, it appears the user cannot have both an EBWS and SOAPProxy. You can use either-- commenting out the compliment-- and it will work.  When both are uncommented, the user gets the following error at deployment time:

--------------------------------------------------------------------------------------------------------------------------------------
 Deployment "jboss.esb.vfszip:/path_to_deployment/Quickstart_webservice_proxy_basic.esb/" is in error due to the following reason(s): java.lang.UnsupportedOperationException
---------------------------------------------------------------------------------------------------------------------------------------
Comment 1 Rick Wagner 2011-02-21 14:56:05 EST
Link: Added: This issue Cloned from SOA-2931
Comment 2 Rick Wagner 2011-02-21 14:56:07 EST
Link: Added: This issue is related to JBESB-3573
Comment 3 Rick Wagner 2011-02-21 14:56:07 EST
Link: Added: This issue duplicates JBESB-3573
Comment 4 Rick Wagner 2011-02-21 14:56:08 EST
Link: Added: This issue related JBESB-3573
Comment 5 Kevin Conner 2011-02-28 07:06:03 EST
This is not an issue for 5.1 as the microcontainer deployment has been rewritten
Comment 6 Kevin Conner 2011-02-28 07:07:36 EST
Not a bug in 5.1.0

Note You need to log in before you can comment on or make changes to this bug.