Bug 780751 - (SOA-3205) Wise SOAPClient SOAPFaultException lost
Wise SOAPClient SOAPFaultException lost
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.1.0 GA
Unspecified Unspecified
high Severity high
: ---
: 5.2.0.ER5
Assigned To: tcunning
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-21 16:48 EDT by david.boeren
Modified: 2011-11-03 07:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-03 07:32:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HelloWS.jar (6.73 KB, application/java-archive)
2011-07-21 16:49 EDT, david.boeren
no flags Details
webservice_consumer_wise_smooks.zip (51.31 KB, application/zip)
2011-07-21 16:50 EDT, david.boeren
no flags Details
webservice_consumer_wise_smooks.zip (46.06 KB, application/zip)
2011-07-22 16:15 EDT, david.boeren
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-3205 None None None Never

  None (edit)
Description david.boeren 2011-07-21 16:48:41 EDT
Help Desk Ticket Reference: https://c.na7.visual.force.com/apex/Case_View?id=500A0000007BBvM&sfdc.override=1
Steps to Reproduce: 1.  Deploy the attached war file on SOA-P 5.1
2.  Unzip the webservice_consumer_wise_smooks.zip into the quickstarts directory
3.  ant deploy
4.  ant runtest
project_key: SOA

Wise will allow expected exceptions to be returned as an InvocationResult but will trap anything it does not recognise and throw it back to the invoker as an exception.  This terminates the pipeline and the remainder of the pipeline is prevented from processing the *valid* SOAP response because wise is turning it into an exception, thereby treating it in a different manner from the exceptions that are defined within the WSDL (and expected).  It is still visible through the exception processing but shouldn't be, it should be treated in the same manner as other SOAP faults.
Comment 1 david.boeren 2011-07-21 16:49:19 EDT
Attachment: Added: HelloWS.jar
Comment 2 david.boeren 2011-07-21 16:50:10 EDT
Attachment: Added: webservice_consumer_wise_smooks.zip
Comment 3 tcunning 2011-07-22 11:02:11 EDT
Link: Added: This issue is related to JBESB-3643
Comment 4 david.boeren 2011-07-22 16:15:16 EDT
This is an updated version fixing a small build.xml bug that would lose the build/META-INF/smooks*.xml files if you did a clean.
Comment 5 david.boeren 2011-07-22 16:15:16 EDT
Attachment: Added: webservice_consumer_wise_smooks.zip
Comment 6 david.boeren 2011-07-28 15:43:22 EDT
Link: Added: This issue relates to SOA-3227
Comment 7 tcunning 2011-08-22 15:42:04 EDT
The fix for this has been committed, but it seems as if there's a regression caused by the Smooks upgrade from ESB 4.9->ESB 4.10.     PropertyChecker.java is not finding the generated bean class the first time the quickstart is run, but any subsequent time, this works fine.
Comment 8 tcunning 2011-08-22 15:42:49 EDT
Link: Added: This issue is related to JBESB-3666
Comment 9 Tom Fennelly 2011-09-08 07:44:34 EDT
So, is the issue associated with this JIRA fixed then?  Sounds like Tom is saying it is, but something else (unrelated to the fix made for this JIRA) is broken because of the upgrade to Smooks v1.4, right?  Or is the regression specifically related to the fix made for this JIRA?  If so, do we know if it fails or not with the previous version of Smooks?

Tom... can you provide more info on the regression please?  Which test is failing etc?
Comment 10 Kevin Conner 2011-09-08 08:35:57 EDT
This may be related to SOA-3321, it would be worth retesting
Comment 11 Kevin Conner 2011-09-08 10:01:21 EDT
The classloading appears to have been addressed by the fix for SOA-3321, the quickstart ran correctly.

One problem I noticed us that the fix is passing information between the SOAPClient and aspect using a system property, which is not safe.  We need to fix this part.
Comment 12 Kevin Conner 2011-09-08 10:12:17 EDT
Link: Added: This issue depends JBESB-3678
Comment 13 tcunning 2011-09-08 17:37:09 EDT
Fixed the system property issue, replaced with ThreadLocal.
Comment 14 David Le Sage 2011-09-25 19:24:44 EDT
Release Notes Docs Status: Added: Documented as Resolved Issue
Writer: Added: dlesage
Release Notes Text: Added: https://issues.jboss.org/browse/SOA-3205
Comment 15 David Le Sage 2011-09-26 22:26:27 EDT
Release Notes Text: Removed: https://issues.jboss.org/browse/SOA-3205 Added: https://issues.jboss.org/browse/SOA-3205

If Wise encountered an error it could not handle, it would terminate the pipeline.  A code fix has been applied so that exceptions are now handled in a consistent manner.
Comment 16 Filip Elias 2011-11-03 07:32:33 EDT
Verified in 5.2.ER6
Comment 17 Filip Elias 2011-11-03 07:32:58 EDT
Verified in 5.2.ER6

Note You need to log in before you can comment on or make changes to this bug.