Bug 78082 - RFE: Add unique text to partition labels
RFE: Add unique text to partition labels
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-18 15:44 EST by Jay Fenlason
Modified: 2014-08-31 19:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-19 14:19:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Fenlason 2002-11-18 15:44:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
When I move a Red Hat Linux root disk from one machine to be a secondary disk on another Red Hat Linux machine, the boot process often mounts the wrong disk as /.  Chaos ensues.  If instead of using "LABEL=/" the installer used "LABEL=/_XYZZY" (with XYZZY chosen randomly at install time), I wouldn't have to hand-edit my /etc/fstab before moving disks.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Move a root disk (sd0) onto a machine with it's root on hd0.
2.Reboot.
3. (if you're lucky) observe the kernel panic when it mounts the wrong root.
	

Additional info:
Comment 1 Bill Rugolsky, Jr. 2002-11-19 14:19:38 EST
You can change the label yourself with "tune2fs -L $label $device",
either on each system, or prior to moving the device elsewhere.
The latter is of course not helpful if you are moving the because
the machine to which it is attached it broken; in that case, it
should be done by prior arrangement, or you should hot-add the
device after booting.

You could also mount everything by UUID.
Comment 2 Jeremy Katz 2002-11-19 14:56:33 EST
The goal isn't to allow people to move disks between machines, it's to make it
so that adding more SCSI adaptors doesn't completely hose you.  Additionally,
using random labels or UUID makes it even less easy to use for the user.
Comment 3 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.