Bug 78123 - Kernel panic during boot on newer notebook w/AMD Athlon XP
Kernel panic during boot on newer notebook w/AMD Athlon XP
Status: CLOSED DUPLICATE of bug 72387
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-19 03:26 EST by Need Real Name
Modified: 2007-03-26 23:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-19 06:53:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-11-19 03:26:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I have installed RH 8.0 on a recently purchased Hewlett Packard Pavilion 
notebook, model ze4115, and now it won't complete the boot process. It stops 
booting and shows a "kernel panic: Unable to continue" message. The last few 
lines read: 
isapnp: Scanning for PnP cards...
CPU 0: Machine Check Exception: 0000000000000007
Bank 3: b40000000000083b at 00000001fc0003b3
Kernel: Unable to continue

I had to type "linux nopcmcia" at the boot: prompt in order to run the 
installation disks, but I don't know if there is a way to do that to boot the 
system that is now installed. I was having a different type of kernel panic 
error when it tried to start up the installation process.

I have had problems installing other linux versions as well and I am starting 
to think that there is a problem with the notebook's hardware. From what I 
understand, my notebook comes equipped with an AMD Athlon XP processor, with an 
ATI U1/ALI 1535+ chipset. I think it also has an integrated graphics processor, 
an ATI Radeon IGP 320m. 
Is there anything I need to do to get linux to run properly on this computer or 
is there a compatibility issue?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH 8.0 using linux nopcmcia at boot prompt
2.restart/or simply try to boot notebook into linux
3.
	

Actual Results:  After the grub or lilo (i've tried both) screen, it attempts 
to boot but quits after only a few seconds. I get this output on the screen:
Dentry cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode cache hash table entries: 16384 (order: 5, 131072 bytes)
Mount cache hash table entries: 4096 (order: 3, 32768 bytes)
Buffer cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: AMD mobile AMD Athlon(tm) XP 1500+ stepping 00
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfd87d, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router ALI [10b9/1533] at 00:07.0
isapnp: Scanning for PnP cards...
CPU 0: Machine Check Exception: 0000000000000007
Bank 3: b40000000000083b at 00000001fc0003b3
Kernel: Unable to continue

After the screen output stops at this point, it does not respond to anything 
but powering down by pressing the power button.

Expected Results:  a successful linux boot.

Additional info:

Like I mentioned earlier, when I used the installation disks, the "linux 
nopcmcia" option at the boot prompt worked OK for me. I had to do this because 
without it, I was getting a different type of kernel panic error when I was 
trying to install. However, this does not work on the kernel that was installed 
on to the hard disk in order to get it to boot properly.
Comment 1 Alan Cox 2002-11-19 06:53:40 EST
Linux doesn't currently support the ATI Radeon IGP chipset, and in addition the
chipset does some very weird and un-PC like things which trip up the current
kernel. 

You may be able to install using the options "nopcmcia" "isapnp=off" "ide=nodma"

Alan
Comment 2 Alan Cox 2002-11-19 06:56:02 EST

*** This bug has been marked as a duplicate of 72387 ***

Note You need to log in before you can comment on or make changes to this bug.