Bug 781448 - Provide native systemd service
Summary: Provide native systemd service
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ganglia
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kostas Georgiou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 751869
TreeView+ depends on / blocked
 
Reported: 2012-01-13 13:16 UTC by Jóhann B. Guðmundsson
Modified: 2012-05-11 17:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-11 14:56:58 UTC


Attachments (Terms of Use)
Native systemd service for gmetad (141 bytes, text/plain)
2012-01-13 13:17 UTC, Jóhann B. Guðmundsson
no flags Details
Native systemd service for gmond (149 bytes, text/plain)
2012-01-13 13:18 UTC, Jóhann B. Guðmundsson
no flags Details
ganglia web frontend patch (2.37 KB, patch)
2012-05-11 17:33 UTC, Terje Røsten
no flags Details | Diff

Description Jóhann B. Guðmundsson 2012-01-13 13:16:34 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2012-01-13 13:17:43 UTC
Created attachment 555069 [details]
Native systemd service for gmetad

Comment 2 Jóhann B. Guðmundsson 2012-01-13 13:18:24 UTC
Created attachment 555070 [details]
Native systemd service for gmond

Comment 3 Fedora Admin XMLRPC Client 2012-01-18 11:25:43 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Kostas Georgiou 2012-02-17 12:18:46 UTC
gmond really needs to start as late as possible at startup. Is there an easy way to do this beyond having a massive After= line listing everything that gmond might be monitoring?

Comment 5 Jóhann B. Guðmundsson 2012-02-17 12:46:57 UTC
order it after multi-user.target as in After=multi-user.target then it's started after multi-user.target is started

Comment 6 Gwyn Ciesla 2012-04-19 19:47:58 UTC
Kostas, any objection to my making this change, with your Johann's suggestion from comment 5?

Comment 7 Gwyn Ciesla 2012-04-24 14:05:47 UTC
Ping?

Comment 8 Terje Røsten 2012-05-07 13:48:19 UTC
There is a typo in description tag for gmond. 

I have created a updated spec file to get things a bit further.

- Update to 3.3.7
- Split buildreq/req
- Remove svn tag
- Fix src url
- Remove patches now upstream
- More man pages
- Move web config # more changes here
- Move ganglia-config to -devel
- Systemd support

Needs more work on the web front end, however gmond/gmetad parts seems ok.

srpm+spec: http://terjeros.fedorapeople.org/ganglia/

Comment 9 Gwyn Ciesla 2012-05-11 14:56:58 UTC
Excellent, thanks.  I removed the enable by default bits, since ganglia's not on the list, but otherwise great work.  Committed and built in rawhide.

Comment 10 Terje Røsten 2012-05-11 17:32:48 UTC
Thanks Jon! 

Could you add the following patch to fix the web frontend too?

Comment 11 Terje Røsten 2012-05-11 17:33:55 UTC
Created attachment 583888 [details]
ganglia web frontend patch

Comment 12 Gwyn Ciesla 2012-05-11 17:56:11 UTC
Done.


Note You need to log in before you can comment on or make changes to this bug.