Bug 781499 - Manpage inaccuracy for makedeltarpm
Manpage inaccuracy for makedeltarpm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Chaloupka
Iveta Wiedermann
: EasyFix, ManPageChange, Patch
Depends On:
Blocks: 1119598
  Show dependency treegraph
 
Reported: 2012-01-13 10:48 EST by jcpunk
Modified: 2014-10-14 03:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: man-pages-overrides-6.6.2-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: description of -l option was missing Consequence: incomplete documentation Fix: description of -l option added Result: updated documentation
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:25:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
makedeltarpm.8 -l obsolete (1.21 KB, patch)
2014-06-23 08:50 EDT, Jan Chaloupka
no flags Details | Diff

  None (edit)
Description jcpunk 2012-01-13 10:48:23 EST
Description of problem:
when run without options, makedeltarpm reports
$ makedeltarpm 
usage: makedeltarpm [-l <file>] [-s seq] oldrpm newrpm deltarpm

However, the manpage makes no reference to the '-l <file>' option

Version-Release number of selected component (if applicable):deltarpm-3.5-0.5.20090913git.el6.x86_64


How reproducible: always


Steps to Reproduce:
1. run makedeltarpm without arguments
2. read the helpful error
3. check manpage to find additional information on the '-l' option
  
Actual results:
no information present

Expected results:
that the manpage would have an accurate list of all options the program accepts

Additional info:
Comment 3 Suzanne Yeghiayan 2012-02-14 18:28:10 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 RHEL Product and Program Management 2013-10-13 20:50:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Jan Chaloupka 2014-06-23 08:50:42 EDT
Created attachment 911425 [details]
makedeltarpm.8 -l obsolete

Specifying  -l  file,  one  can  give a file with list of files needed to be excluded from the delta process. Nowadays it is relayed on all of those files be either marked as %config or as %verify(nomd5) in the spec files. Thus, this option is obsolete.
Comment 13 errata-xmlrpc 2014-10-14 03:25:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html

Note You need to log in before you can comment on or make changes to this bug.