Bug 78159 - missing elinks dependency
Summary: missing elinks dependency
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 16:13 UTC by Chris Ricker
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version: 2.0.40-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-19 09:15:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2002-11-19 16:13:47 UTC
The httpd RPM should Require elinks, since /usr/sbin/apachectl runs "links
-dump" to access status reports. The httpd spec currently isn't requiring
elinks, so things like

/etc/init.d/httpd fullstatus

won't always work

Comment 1 Joe Orton 2002-11-25 14:19:41 UTC
I think it would be a overkill to enforce a package dependency for this rather
obscure feature; better to just print "elinks package missing" if ! test -x
/usr/bin/links.  (especially since server-status isn't enabled in the default
httpd.conf)

Comment 2 Bill Nottingham 2002-12-19 16:27:48 UTC
If links isn't installed, you can always telnet to the port and dump the output ;)


Comment 3 Joe Orton 2003-05-19 09:15:37 UTC
This was fixed in 2.0.40-17, thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.