Bug 78177 - kernel panic if no hard drive installed
kernel panic if no hard drive installed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-11-19 14:05 EST by Matthew Miller
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 08:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2002-11-19 14:05:10 EST
Description of Problem:

I was testing the install using the netboot floppy. Started to boot okay, and
then kernel panicked. Quick look determined that I'd unplugged the harddrive
cable accidentally while messing around with some other hardware.

Version-Release number of selected component (if applicable):


How Reproducible:

Yep.

Steps to Reproduce:
1. unplug harddrive
2. try to run installer from netboot floppy (possibly in other ways too)
3. 

Actual Results:

panic

Expected Results:

Some sort of pretty little dialog box telling me that I'm a moron for not having
a hard drive.

Additional Information:
	
Or actually, I suppose if some hardware incompatibility is causing a drive to
not be recognized even when it exists, it might be good for the message to
explain that perhaps that is the problem. Not just the moron thing.
Comment 1 Michael Fulbright 2002-11-20 10:08:37 EST
Did the kernel panic before the anaconda loader started? If so this bug should
be filed against the kernel component.
Comment 2 Matthew Miller 2002-11-20 11:10:09 EST
Yeah, it happens right away, very early as the kernel is starting up. The actual
messages is: "<0>Kernel panic: attempted to kill init!"
Comment 3 Pedro Miguel Marques Morais 2002-12-01 15:02:06 EST
The same happened to me (hard drive cable disconnected), but I couldn't 
even get ISOLINUX to boot the CDs for me. 
Don't know if this is the best place to report it, but anyway, here's 
what isolinux said: 
 
ISOLINUX: loading spec packed failed, trying to (can't read what I wrote :-) 
it ... 
ISOLINUX: extremely broken bios detected, last ditch attempt with drive=9F 
ISOLINUX: disk error 01, AX=425, drive 9F 
 
Boot failed: press any key to retry... 
 
Now, everything worked after I found the unplugged cable and the CD was ok 
(mediacheck passed). 
Also, the press any key to retry is wrong, if you press a key nothing happens.
Comment 4 Bill Nottingham 2003-02-19 21:15:50 EST
Does this persist with the third public beta?
Comment 5 Matthew Miller 2003-02-19 21:20:57 EST
Dunno. Tomorrow I'll yank out the hard drive and try again. :)
Comment 6 Matthew Miller 2003-02-24 14:11:29 EST
Works for me now.

Note You need to log in before you can comment on or make changes to this bug.