Bug 781789 - Hibernate doesn't work
Hibernate doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-01-15 03:08 EST by Philip
Modified: 2012-03-22 15:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-22 15:56:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip 2012-01-15 03:08:55 EST
Description of problem:

On Hibernate (i.e. KDE Kickoff - Leave - Hibernate), I immediately get a black screen with those two lines:
PM: Syncing file systems ...
Freezing user space processes ...

A few seconds later, the screen turns black, but instead of hibernating, the session is locked. When I move the mouse, I can enter my password and I'm back where I started. Only the NIC seems to be temporarily deactivated.



Version-Release number of selected component (if applicable):

Fedora 16, up to date

How reproducible:


Steps to Reproduce:
1. Trigger hibernation
  
Actual results:

Session locked.

Expected results:

Hibernation.

Additional info:

MB: Asus SABERTOOTH 990FX

http://www.smolts.org/client/show/pub_d0f43508-eca8-4be6-8e92-4d5a8b9eaec9
Comment 1 Dave Jones 2012-03-22 12:59:54 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 2 Dave Jones 2012-03-22 13:03:44 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 13:14:33 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Philip 2012-03-22 15:56:52 EDT
The swap partition was smaller than the total amount of physical RAM (16 GB).
I've repartitioned the hdd, the swap partition is now more than double the size of my RAM. Hibernate is working fine now. Although I've tested this with Kernel 3.1.8-2.fc16.x86_64, this was probably the only reason it didn't work in the first place. I just didn't see an error message indicating the insufficient amount of swap space (I might have overlooked it in the log but there certainly didn't appear any when trying to hibernate).

Sorry for the misleading bug ticket, but thanks anyway.

Since it's working now, I'll close this ticket.

Note You need to log in before you can comment on or make changes to this bug.