Bug 782149 - Provide native systemd service
Summary: Provide native systemd service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: icecast
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 751869
TreeView+ depends on / blocked
 
Reported: 2012-01-16 16:32 UTC by Jóhann B. Guðmundsson
Modified: 2012-03-06 20:46 UTC (History)
4 users (show)

Fixed In Version: icecast-2.3.2-7.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-24 13:39:28 UTC


Attachments (Terms of Use)
Native systemd service file for icecast (224 bytes, text/plain)
2012-01-16 16:32 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2012-01-16 16:32:23 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2012-01-16 16:32:59 UTC
Created attachment 555551 [details]
Native systemd service file for icecast

Comment 2 Gwyn Ciesla 2012-02-14 16:59:29 UTC
Andreas, any objection to my making this change?

Comment 3 Petr Pisar 2012-02-24 13:22:57 UTC
Current init script implementation does not work in F16. I'm pushing move-to-systemd into F18 branch which works fixes this issue. According koji history, there has not been any development in last few years.

Comment 4 Gwyn Ciesla 2012-02-24 13:28:14 UTC
Ok, great, thanks, let me know if you need me to do anything!

Comment 5 Petr Pisar 2012-02-24 13:39:28 UTC
I would like to push this change into F17. But I'm not sure if this is not against guidelines forbidding to do systemd-move in stable release. What do you think?

Comment 6 Gwyn Ciesla 2012-02-24 13:49:55 UTC
I've been leaving the ones I've been doing on F18.  That said, if the sysvinit script is broken anyway, and we're still barely pre-alpha, I suspect it's probably a good idea to get it into f17 pronto.

Comment 7 Petr Pisar 2012-02-24 14:04:18 UTC
I asked FESCo <https://fedorahosted.org/fesco/ticket/809>.

Comment 8 Jóhann B. Guðmundsson 2012-02-24 14:09:02 UTC
During the F16 cycle it was allowed to introduce units to beta ( and I think Tom actually went week or two over that deadline ) but after speaking with Kevin he mentioned that this should be brought up again on fesco meeting I just pointed it out to him that there was absolutely nothing new on the table that warranted it not to be. 

I was going to bring this in open discussions in this weeks meeting but then there was no meeting which means maintainers that want to push this past feature freeze late into the distribution cant or at least cant until they have sanction it based on Kevins response.

Thank bureaucracy and people that have been elected in governing body's for this distribution not being able hold or attend those few meetings they are supposed to do.

Comment 9 Marcela Mašláňová 2012-02-24 14:22:26 UTC
(In reply to comment #8)
> During the F16 cycle it was allowed to introduce units to beta ( and I think
> Tom actually went week or two over that deadline ) but after speaking with
> Kevin he mentioned that this should be brought up again on fesco meeting I just
> pointed it out to him that there was absolutely nothing new on the table that
> warranted it not to be. 
> 
> I was going to bring this in open discussions in this weeks meeting but then
> there was no meeting which means maintainers that want to push this past
> feature freeze late into the distribution cant or at least cant until they have
> sanction it based on Kevins response.
> 
> Thank bureaucracy and people that have been elected in governing body's for
> this distribution not being able hold or attend those few meetings they are
> supposed to do.

I don't think it would be solved in one meeting. It's much better to provide ticket in advance, so members of FESCo can look at it. Especially if you have a list of services which should be fixed.

Comment 10 Jóhann B. Guðmundsson 2012-02-24 15:10:42 UTC
(In reply to comment #9)
> (In reply to comment #8)
> I don't think it would be solved in one meeting. It's much better to provide
> ticket in advance, so members of FESCo can look at it. Especially if you have a
> list of services which should be fixed.

This already got discussed to death last release cycle no need to bring it up again for the sake of just bringing it up unless something has changed. 

And as far as I know nothing has changed and nor could Kevin mention anything in that regard when asked. 

So if FESCO wants to play unnecessary politics I'm not going to stop them.

This sysv systemd migration wont be finished anyway until F20+ at current rate due to packagers being either to incompetent or non existing to make these [1] few spec file adjustments which should not take any more then 15 minutes half an hour tops to perform once they have had submitted units. ( and yes we are way past any points packagers could try to use as an excuse for not doing this by now and and yes that includes the excuse I have heard from some Red Hat maintainers not being allowed to work on it until it's been approved by their manager which begs the question how many of them are forced to work on maintaining packages in Fedora or are otherwise only doing so because they have to because of some clause in the job contract ).

The only excuse that is valid for this not happening if any code changes are required to make this change which is rather an exception than a rule,.

Last release cycle it was Toshio and Tom that were forced to clean up some of their co-workers and the community packagers mess. 

This time Jon has stepped up to do that work.

Meanwhile the users base suffers and other related systemd clean up stuff is put on hold and feature proposal that take aim of some of the advantages that systemd has to offer cant be finished because the relevant components in question have not been migrated!

I have not spent countless hours of looking at legacy sysv init scripts some of which would make most people vomit or jump off an tall building for over 3 release cycles ( 4 if we count the initial F14 attempt )and migrate them to native systemd units only to have them stuck in bugzilla and then listen to myself and the rest of the systemd crew take countless shit and flames from others in process for things being as bad as they are.

1. 

# Systemd

# Adding the submitted unit

Source1: %{name}.service

# Adding the build require

BuildRequires: systemd-units

# Adding the requires

Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units

#%install...

# Create the unit directory

mkdir -p %{buildroot}%{_unitdir}

# Install the unit file which is SOURCE1

%{__install} -p -D -m 0644 %{SOURCE1} %{buildroot}%{_unitdir}/%{name}.service

# Drop the legacy sysv inits script if applicable

rm -rf %{buildroot}%{_initrddir}

# Initial systemd installation

%post
if [ $1 -eq 1 ] ; then
# Initial installation
%{_bindir}/systemctl daemon-reload >/dev/null 2>&1 || :
# Only applicable if service has been granted exception from fesco
# to be enabled by default
%{_bindir}/systemctl enable %{name}.service >/dev/null 2>&1 || :
fi

# systemd package removal not upgrade

%preun
if [ $1 -eq 0 ]; then
# Package removal, not upgrade
%{_bindir}/systemctl --no-reload disable %{name}.service > /dev/null 2>&1 || :
%{_bindir}/systemctl stop %{name}.service > /dev/null 2>&1 || :
fi

# systemd package upgrade not removal

%postun
%{_bindir}/systemctl daemon-reload >/dev/null 2>&1 || :
if [ $1 -ge 1 ] ; then
# Package upgrade, not removal
%{_bindir}/systemctl try-restart %{name}.service >/dev/null 2>&1 || :
fi

%triggerun -- %{name} < $bla release
# Save the current service runlevel info
# User must manually run systemd-sysv-convert --apply %{name}
# to migrate them to systemd targets
%{_bindir}/systemd-sysv-convert --save %{name} >/dev/null 2>&1 ||:

# Run these because the SysV package being removed won't do them
%{_sbindir}/chkconfig --del %{name} >/dev/null 2>&1 || :
%{_bindir}/systemctl try-restart %{name}.service >/dev/null 2>&1 || :

#%files ...
%{_unitdir}/%{name}.service

Comment 11 Marcela Mašláňová 2012-02-24 15:48:35 UTC
I can't stop wonder if units are so cool thing and they have many proponents, why no-one from them step in and work on them? From the current state it doesn't look like that people are fond of this feature.

Back to the previous problem. I guess it makes sense to give exception to every package, which doesn't have functional sysvinit script now.

Comment 12 Jóhann B. Guðmundsson 2012-02-24 16:10:31 UTC
(In reply to comment #11)
> I can't stop wonder if units are so cool thing and they have many proponents,
> why no-one from them step in and work on them? 

Not following I am working on it and Lennart is just a name on paper on that proposal which is interesting since people have asked him and kay to tell them how to migrate when you are speaking with the only person that has well still am because I have lost team members from the migration grew due to the what I mentioned above. 

people ( in this case packagers/maintainers ) dont work on things they do not understand thus cant do anything about it,such is human behaviour in general.

> From the current state it
> doesn't look like that people are fond of this feature.

What people think is irrelevant once FESCO has reach decision and blocking things based on personal believe is just naive.

Basically once a decision has been made everybody should work together on finishing it despite their "feelings".

Ofcourse the same thing seems to be start happening with journal which is lining up to be followed by the same ignorance, flames and shit.

> Back to the previous problem. I guess it makes sense to give exception to every
> package, which doesn't have functional sysvinit script now.

It makes sense that the same rules apply that did for the last release cycle as in packagers/maintainers will be granted exception to introduce units up to beta unless of course something new has been brought to the table to prevent it 
( unless fesco loves being in contradiction with itself. )

Comment 13 Fedora Update System 2012-02-28 09:46:22 UTC
icecast-2.3.2-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/icecast-2.3.2-7.fc17

Comment 14 Fedora Update System 2012-03-06 20:46:54 UTC
icecast-2.3.2-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.