Bug 78229 - mogrify is broken since RH8
mogrify is broken since RH8
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Depends On:
  Show dependency treegraph
Reported: 2002-11-20 08:36 EST by Boris Folgmann
Modified: 2012-04-24 16:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-25 01:17:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch for mogrify(1) in ImageMagick-5.4.7 (542 bytes, patch)
2002-12-22 16:06 EST, Emmanuel Kowalski
no flags Details | Diff

  None (edit)
Description Boris Folgmann 2002-11-20 08:36:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.1) Gecko/20020829

Description of problem:
mogrify (bulk image transformation) seems to be broken in ImageMagick-5.4.7-5
included in RedHat 8.
May be it has something to do with the GIF compression. Did you change anything
in ImageMagick because of patent problems?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Get a big GIF.
2. Enter "mogrify -scale 120 big.gif" in the shell

Actual Results:  3. you get no error message
4. big.gif has not changed it's size
5. temp file big.mgk was left behind

Expected Results:  mogrify should scale down the image to a maximum width of 120
pixels, as did ImageMagick- included in RedHat 7.3.

Additional info:

Here is my example trace for you:

boris@titan tmp$ ll Geosonde.gif
-rw-rw-r--    1 boris    boris        8003 Nov 20 14:28 Geosonde.gif
boris@titan tmp$ gifinfo Geosonde.gif
Size: 320x200
boris@titan tmp$ mogrify -scale 120 Geosonde.gif
boris@titan tmp$ ll Geosonde.*
-rw-rw-r--    1 boris    boris        8003 Nov 20 14:28 Geosonde.gif
-rw-rw-r--    1 boris    boris       11010 Nov 20 14:29 Geosonde.mgk
boris@titan tmp$ gifinfo Geosonde.gif
Size: 320x200
boris@titan tmp$ gifinfo Geosonde.mgk
Size: 120x75
Comment 1 Boris Folgmann 2002-11-20 08:38:54 EST
I did not attach my picture, because it's copyrighted and should not be released
to the public right now. I can send it to you in an email, if you lack an
example picture.

Comment 2 Emmanuel Kowalski 2002-12-22 15:16:23 EST
It is not a GIF issue, mogrify does the same with  other image types
and other transformations (tried with JPEGS, and scaling as well as
rotating). On the other hand, the '.mgk' files seem to be the right ones
since they seem to be the same as those produced by a convert(1) command
instead (checked with md5sum on a JPEG rescaling).
Comment 3 Emmanuel Kowalski 2002-12-22 16:06:04 EST
Created attachment 88859 [details]
Patch for mogrify(1) in ImageMagick-5.4.7

After looking at the source, it seems to be just a typo in utilities/mogrify.c,

which the patch above corrects (if I understand things right...)
Comment 4 Emmanuel Kowalski 2002-12-23 08:25:19 EST
I have checked the correctness of the patch above by comparing with the
version of ImageMagick in Redhat 7.3 which ``incorporates'' it...
Comment 5 Boris Folgmann 2003-03-03 11:38:56 EST
Is it fixed in rawhide?
Comment 6 Emmanuel Kowalski 2003-03-03 14:45:01 EST
It is still broken (in the same way) in Rawhide and Phoebe (I checked the SRPM 
and did a quick test by building the tarball, without applying the Redhat
patches; however, none seemed to be relevant).

      Emmanuel Kowalski
Comment 7 Kurt Zingler 2003-06-10 02:13:49 EDT
You can fix this problem with the rpms from ImageMagick (ver 5.5.7)
Comment 8 Boris Folgmann 2003-08-21 08:42:58 EDT
Still not fixed in Red Hat 9A.
Anybody at Red Hat reading this?
Comment 9 Boris Folgmann 2004-04-01 08:53:17 EST
RedHat released no update for RedHat 9.
One can upgrade to ImageMagick- from Fedora Core
1.90. It can be installed w/o any dependency trouble.
Comment 10 William Gomeringer 2012-04-24 16:29:27 EDT
*** Bug 812194 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.