Bug 782471 - Propose that you turn on PrivateTmp=true in service file for Zarafa
Summary: Propose that you turn on PrivateTmp=true in service file for Zarafa
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: zarafa   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PrivateTmp
TreeView+ depends on / blocked
 
Reported: 2012-01-17 15:10 UTC by Daniel Walsh
Modified: 2012-02-06 20:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-06 20:54:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Walsh 2012-01-17 15:10:03 UTC
I would like to propose using PrivateTmp for Zarafa, to make it more secure
and avoid users from being able to potentially effect it.

http://fedoraproject.org/wiki/Features/ServicesPrivateTmp

Comment 1 Robert Scheck 2012-01-17 15:14:12 UTC
I am tempted to use /var/lib/zarafa/autoresponder (or similar) instead of
/tmp, because /tmp is on recent Fedora anyway on a ramfs, thus /tmp gets
emptied out during reboots and all set up autoresponder history data are
gnone, too. It's anyway not really temporary data, but application created
data that should exist as long as it's needed. Objections?

Comment 2 Daniel Walsh 2012-01-17 16:28:52 UTC
No that would be perfect.  I don't believe any privileged process should use /tmp.

/tmp is for users /var/lib and /run are for system processes...

Comment 3 Daniel Walsh 2012-02-06 20:45:52 UTC
Any change on this bug.  We are coming up to Feature Freeze, and would like some comment on this bug.

If you do not believe this application uses /tmp than please comment on this and close the bug.  

If you believe this application needs to use /tmp to communicate with other applications or users then you can close this bug with that comment.

If your app does not use systemd, then close this bug with that comment.

If you have no idea, then please add a comment, and change the bug to assigned.

I need to update the status on this feature.


Thanks for your help.

Comment 4 Robert Scheck 2012-02-06 20:54:49 UTC
Zarafa does not yet use systemd. The usage of /tmp is not related to the
initscript, however there might be a /tmp usage of the initscript which I
need to discuss with upstream anyway. But can't be solved without systemd
switching for now anyway.


Note You need to log in before you can comment on or make changes to this bug.