Bug 782489 - Consider maintaining and running developer modules/cli-tests
Summary: Consider maintaining and running developer modules/cli-tests
Status: CLOSED WONTFIX
Alias: None
Product: RHQ Project
Classification: Other
Component: CLI   
(Show other bugs)
Version: 4.3
Hardware: Unspecified
OS: Unspecified
medium
urgent vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon24-cli jon310-sprint11, rhq44-sprint11
TreeView+ depends on / blocked
 
Reported: 2012-01-17 15:31 UTC by Mike Foley
Modified: 2012-05-11 17:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-11 17:24:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TestNG report (86.33 KB, text/xml)
2012-01-17 17:15 UTC, Stefan Negrea
no flags Details

Description Mike Foley 2012-01-17 15:31:32 UTC
Description of problem:  Consider running developer modules/cli-tests either in Jenkins or in another environment.  The tests have not been running in Jenkins and have not been run manually.  When run (requires a running RHQ Server) 16 of 19 tests fail.  Some of the failures are due to usage of the CLI API that no longer exists.   This is not sufficient to prevent regressions in the CLI.


Version-Release number of selected component (if applicable):  RHQ 4.3


How reproducible:
100%.  per Stefan scrum update 1/17/2012.


Actual results:   16 of 19 CLI tests fail.


Expected results:   19 of 19 tests pass.

Comment 1 Stefan Negrea 2012-01-17 17:15:29 UTC
Created attachment 555830 [details]
TestNG report

TestNG report from running the tests on my local box. 16 failed tests out of a total of 19.

Comment 2 Mike Foley 2012-01-23 16:17:23 UTC
per scrum 1/23/2012 crouch, loleary, mfoley

Comment 3 Jay Shaughnessy 2012-05-11 17:24:03 UTC
(1:22:10 PM) jshaughn: mfoley: Is https://bugzilla.redhat.com/show_bug.cgi?id=782489 still relevant or are these tests basically superseded by your cli automation effort?
(1:22:23 PM) mfoley: 1 sec
(1:22:51 PM) mfoley: we got the CLI automation effort
(1:23:02 PM) mfoley: you can close that BZ 
(1:23:06 PM) jshaughn: sweet
(1:23:16 PM) mfoley: or i can do that
(1:23:22 PM) jshaughn: I'll do it
(1:23:35 PM) mfoley: yeah our CLI automation tests are running every night no issues


Note You need to log in before you can comment on or make changes to this bug.