Bug 782504 - Propose that you turn on PrivateTmp=true in service file for fail2ban
Propose that you turn on PrivateTmp=true in service file for fail2ban
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fail2ban (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PrivateTmp
  Show dependency treegraph
 
Reported: 2012-01-17 10:43 EST by Daniel Walsh
Modified: 2013-03-15 16:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 16:12:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2012-01-17 10:43:15 EST
I would like to propose using PrivateTmp for fail2ban systemd unit file
This should make the use of /tmp directory more secure
and avoid users from being able to potentially effect it.

http://fedoraproject.org/wiki/Features/ServicesPrivateTmp
Comment 1 Daniel Walsh 2012-02-06 15:45:48 EST
Any change on this bug.  We are coming up to Feature Freeze, and would like some comment on this bug.

If you do not believe this application uses /tmp than please comment on this and close the bug.  

If you believe this application needs to use /tmp to communicate with other applications or users then you can close this bug with that comment.

If your app does not use systemd, then close this bug with that comment.

If you have no idea, then please add a comment, and change the bug to assigned.

I need to update the status on this feature.


Thanks for your help.
Comment 2 Daniel Walsh 2012-02-07 17:00:30 EST
This looks like it does not support systemd yet, so please use this flag when you do.
Comment 3 Orion Poplawski 2013-03-15 16:12:14 EDT
Uses /var/run/fail2ban now instead of /tmp.

Note You need to log in before you can comment on or make changes to this bug.