Bug 782725 - WARNING: no socket to connect to in svn
WARNING: no socket to connect to in svn
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
: 768473 770645 782799 783093 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-18 04:30 EST by David Nečas
Modified: 2015-03-03 18:04 EST (History)
11 users (show)

See Also:
Fixed In Version: gnome-keyring-3.2.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-19 16:57:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Nečas 2012-01-18 04:30:48 EST
Description of problem:
Running subversion commands outside the GUI (e.g. from text console, ssh, cron jobs, ...) always prints:

WARNING: no socket to connect to


Version-Release number of selected component (if applicable):
gnutls-2.12.14-1.fc16.x86_64
gnome-keyring-3.2.1-2.fc16
subversion-1.6.17-5.fc16.x86_64


How reproducible:
Always.


Steps to Reproduce:
1. (as root) useradd foobar
2. log in to the text console as foobar
3. (as foobar) svn info https://gwyddion.svn.sourceforge.net/svnroot/gwyddion

(It can be probably reproduced without creating a fresh user but this ensures the socket does not exist and has never existed.)

  
Actual results:
Prints `WARNING: no socket to connect to' and then prints the requested info.


Expected results:
No WARNING is printed, just the requested info.


Additional info:
The warning seems to be actually produced by a gnome-keyring module (and removing gnome-keyring removes the warning as the module is no longer loaded by svn).

However, the problem appeared after upgrading to gnutls-2.12.14-1.fc16.x86_64.  Downgrading to gnutls-2.12.7-2.fc16 removes the warning.

I do not know who to blame so reporting to the last changed package.

The relevant part of stracing the `svn info' command:

open("/etc/pkcs11/pkcs11.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/etc/pkcs11/modules", O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC) = 4
getdents(4, /* 3 entries */, 32768)     = 88
open("/etc/pkcs11/modules/gnome-keyring-module", O_RDONLY) = 5
fstat(5, {st_mode=S_IFREG|0644, st_size=293, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f8f9e7b5000
fstat(5, {st_mode=S_IFREG|0644, st_size=293, ...}) = 0
lseek(5, 0, SEEK_SET)                   = 0
read(5, "\n# The file is installed/loaded "..., 293) = 293
lseek(5, 293, SEEK_SET)                 = 293
lseek(5, 293, SEEK_SET)                 = 293
close(5)                                = 0
munmap(0x7f8f9e7b5000, 4096)            = 0
getdents(4, /* 0 entries */, 32768)     = 0
close(4)                                = 0
open("/usr/lib64/pkcs11/gnome-keyring-pkcs11.so", O_RDONLY|O_CLOEXEC) = 4
read(4, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0`<\0\0\0\0\0\0"..., 832) = 832
fstat(4, {st_mode=S_IFREG|0755, st_size=80696, ...}) = 0
mmap(NULL, 2176048, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 4, 0) = 0x7f8f9156a000
mprotect(0x7f8f9157c000, 2093056, PROT_NONE) = 0
mmap(0x7f8f9177b000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 4, 0x11000) = 0x7f8f9177b000
close(4)                                = 0
mprotect(0x7f8f9177b000, 8192, PROT_READ) = 0
write(2, "WARNING: no socket to connect to"..., 33) = 33
Comment 1 Tomas Mraz 2012-01-18 04:40:47 EST
It happens after the upgrade because the upgrade adds support for pkcs11 modules through p11-kit.

gnome-keyring module simply should not spit out any such warnings.
Comment 2 Sebastian Ade 2012-01-18 04:50:35 EST
Same problem with virsh and virt-manager. On every launch the warning is printed. Downgrading to gnutls-2.12.7-2.fc16.x86_64 works.
Comment 3 Tomas Mraz 2012-01-18 06:05:55 EST
Note that the gnome-keyring version in rawhide has the message removed already.
Comment 4 Fedora Update System 2012-01-18 09:07:50 EST
gnome-keyring-3.2.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-keyring-3.2.1-3.fc16
Comment 5 Tomas Mraz 2012-01-18 10:04:19 EST
*** Bug 782799 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-01-18 20:29:13 EST
Package gnome-keyring-3.2.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-keyring-3.2.1-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0658/gnome-keyring-3.2.1-3.fc16
then log in and leave karma (feedback).
Comment 7 Eric Blake 2012-01-18 21:19:10 EST
*** Bug 770645 has been marked as a duplicate of this bug. ***
Comment 8 Eric Blake 2012-01-18 21:19:47 EST
*** Bug 768473 has been marked as a duplicate of this bug. ***
Comment 9 Tomáš Bžatek 2012-01-19 05:42:21 EST
*** Bug 783093 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2012-01-19 16:57:54 EST
gnome-keyring-3.2.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Sergei Nikulov 2012-01-24 22:32:27 EST
It looks like this is solved the issue partly:

"svn info" does not show this warning, but "svn up" still 

-------------------------
[snikulov@snikulov X1.5i.3.0.2.MOL]$ svn up
WARNING: couldn't connect to: /tmp/keyring-Iq64YM/pkcs11: No such file or directory
At revision 4482.
[snikulov@snikulov X1.5i.3.0.2.MOL]$ svn info
Path: .
URL: https://trac.rhonda.ru/svn/exalt/X1.5i.3.0.2.MOL
Repository Root: https://trac.rhonda.ru/svn/exalt
Repository UUID: 77bf9ec7-748b-45e2-a450-bd5d346488ab
Revision: 4482
Node Kind: directory
Schedule: normal
Last Changed Author: snikulov
Last Changed Rev: 4479
Last Changed Date: 2012-01-25 12:49:35 +1100 (Wed, 25 Jan 2012)
-------------------------

Version-Release number of selected component (if applicable):

gnutls-2.12.14-1.fc16.x86_64
subversion-1.6.17-5.fc16.x86_64
gnome-keyring-3.2.1-3.fc16.x86_64

Note You need to log in before you can comment on or make changes to this bug.